cURL error 60: SSL certificate problem: self signed certificate in certificate chain

I’m using Let’s Encrypt and I am getting this error when I click on office:

cURL error 60: SSL certificate problem: self signed certificate in certificate chain

I installed it like the guide here:

Where could the problem be?

I have the next error.

Collabora Online: Certificado SSL inválido.Por
favor pida a su administrador que añada una cadena ca-chain.cert.pem a
ownCloud’s ca-bundle.crt, por ejemplo “cat
/etc/loolwsd/ca-chain.cert.pem >>
owncloud/resources/config/ca-bundle.crt” . El mensaje de error exacto
fue: cURL error 60: Peer certificate cannot be authenticated with known
CA certificates

The docker have it installed on the same server nextcloud.
I have reviewed the file /resources/config/ca-bundle.crt its ok.
I have a certificate with an external entity GlobalSing and is ok.
Server: Centos 6.7
9.0.52 Nextcloud

I had the same problem, added the ca certificate, but the error mesage was still there. At least i have found a solution. The problem was the app which don’t write back the configured URL for collabora online. Also it is mentioned in another thread that the entry should be written and only the visible response is missing, for me this don’t work. I have checked the setting with mysql directly : select * from oc_appconfig where appid = ‘richdocuments’. And the entry for the configkey wopi_url was still wrong. So i have update the table with: update oc_appconfig set configvalue = ‘https://my.private.domain:443’ where appid = ‘richdocuments’ and configkey = ‘wopi_url’. After cleaning some browser caches and restarting php-fpm and nginx i could access collabora online. There are still some problems with opening documents, but these are discussed in another threat.

It was my mistake not set well the wopi_url

You can do it from the database (egon) or from of Administrator- > Collabora Online-> Server Collabora Online

Now I disappeared error and I can access.
Now is present a problem in mod_proxy, but that already nothing has that view with the error cURL 60

For me this worked thank you.


I have the same error.“cURL error 60: SSL certificate problem: unable to get local issuer certificate”.
My certificates are from startssl and the CA is present in the resources/config/ca-bundle.crt file.

Also the address in the database is correct (wopi_url).
Have you got another idea what I can check?
Is there a way to disable https and just use http instead? Nextcloud and Collabora are running on the same server and nextcloud is already secured through https, so I don’t get the point why a local connection should be encrypted.

I am running both on debian wheezy (7.11) with apache 2.2.22
The Collabora Docker image and nextcloud are up-to-date.

I’m trying to solve the same problem now