cURL error 3 on Microsoft Office documents

Servus Community,

I maintain a Nextcloud version 20 instance on a Debian server version 10 (Buster) and I have problems to open Microsoft Office documents with the iOS App (iOS 13.3.1; NC The app terminates with an error (cURL error 3) and is not usable after that. I have to terminate the application to get back to the menu. This happens reproducibly with all Office documents (docx; xlsx) but only in the iOS app, on the desktop PCs they can be opened without problems. PDF documents don’t cause any problems either.

Can anyone comment on this or know where to look for the problem?

Thx & Bye Tom

Hi Pronto,

Do you have any office integrations running such as a Collabora server running or Online Office? I ran into this problem because I didn’t have Collabora setup as a docker alongside my Nextcloud docker. I also then ran into issues because I had both Collabora and Online Office Integration enabled as Nextcloud apps. Disabling and removing the Online Office Integration and setting up Collabora properly fixed this issue for me.

Have you solved it and Microsoft Office docs works?

Hi Alexander,

sorry for my late feedback. I have now disabled Collabora Online and I do not have an Office Online app installed. I can now open Office documents on iOS again but not all of them. I don’t get any more error messages with the documents, which still can’t be opened, but the document seems to be downloaded, which is indicated by a green check mark, but then there is only the file name, the file size and the notice of an Open Office document, which is not true, it is a Microsoft Office document, but from Office for Mac, but so are the others. I haven’t found any similarities yet, except that the documents that can’t be opened are in the same folder.

Sorry again for my beeing late but I was still involved in many changes of my infrastructure.

Thx & Bye Tom