Cronjob and nextcloud config

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 16.0.1):
Operating system and version (eg, slackware 14.2):
Apache or nginx version (eg, nginx 1.15.12 ):
PHP version (eg, 7.3.4):

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N):

Steps to replicate it:

  1. Change the setting of cronjob of nextcloud (cron.php) in the crontab to */5 * * * * (from 15mins to 5mins)
  2. login as admin to nextcloud, and goto Settings->Basic Settings
  3. at Background jobs section, it still report
    Use system cron service to call the cron.php file every 15 minutes. The cron.php needs to be executed by the system user “user”.

I check that the cronjob (cron.php) runs every 5 mins, but, for example, the Activity email is sent out every 15mins instead of 5mins.

Just want to ask is there any parameter I need to change in the config.php to set the background job interval?