Cron not Working anymore

I do run my own NC version on my synology NAS in a Docker Container.

Unfortunaly my corn job do not work anymore. I don’t know why but I do know when and what I did.

On my Synology NAS I had to update the PHP 7.4 Package and the Node js v12. So I did this. And since then my corn job, wich I execute with a script in the task planner from synology, do not reach the nc instant. So the script is executing with
curl --insecure

This worked fine for the last two years.

So I do think the problem is not on my nextcloud, because I did not change naything there. But I updated the php 7.4 and this has an impact on the script task.

Can anyone help me?

my nx version is 24.0.2
my DSM is 6.2.4
php version on my NAS is now, 7.4.30


my cron job is not working, no matter if if try in webcron, ajax oder cron.

for webcron I do have a task in synology taskmanager this look like so:
curl --insecure

if I do open the link in a brower I get a success message, but nextcloud is stil teling me that since a couple of days it hast not been executed.

It worked fine for the last year and after an update of the php in synology, it stoped. So it has somthing to do with this update. But why? I do run nexcloud in a docker container, so in my understanding, the php update of the synology should not affect the docker container php version. But obviously I’m wrong.

What can I do to make it work again.

If I do cron from the system, it dosn’t work either. The synology task scrip look like this:
/bin/su -s /bin/sh -c “/usr/local/bin/php74 -f /volume1/docker/nextcloud24/app/cron.php” http

or another look like this
sudo -u http php74 -f /volume1/docker/nextcloud24/app/cron.php

both do not work, and my nextcloud tells me, that this is still not working.

Can anyone help me, I do need the cron to run to make some task of taging a couple of files on my system.


I did now a new task with this script and it seams to work fine :slight_smile:

docker container exec --user www-data -t CONTAINER NAME php cron.php

Nextcloud is in crone mode.