Cron job cannot be completed

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version 19.0.1
Operating system and version Linux 4.19.0-10-amd64 x86_64 (containerlized)
Apache or nginx version Nginx:
PHP version 7.1:
The issue you are facing:
the cron job is not completed

Is this the first time you’ve seen this error? (Y/N): Y

The output of your Nextcloud log in Admin > Logging:

[PHP] Error: session_start(): A session had already been started - ignoring at /var/www/html/lib/private/Session/Internal.php#209

GET /index.php/apps/notes/api/v1/notes?pruneBefore=1597300436
from 120.194.97.34 at 2020-08-13T06:51:06+00:00

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'apps_paths' =>
  array (
    0 =>
    array (
      'path' => '/var/www/html/apps',
      'url' => '/apps',
      'writable' => false,
    ),
    1 =>
    array (
      'path' => '/var/www/html/custom_apps',
      'url' => '/custom_apps',
      'writable' => true,
    ),
  ),
  'instanceid' => '',
  'passwordsalt' => '',
  'secret' => '+',
  'trusted_domains' =>
  array (
    0 => ',
  ),
  'datadirectory' => '/var/www/html/data',
  'dbtype' => 'mysql',
  'version' => '19.0.1.1',
  'overwrite.cli.url' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'mariadb',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '',
  'dbpassword' => '',
  'installed' => true,
);

The output of your Apache/nginx/system log in /var/log/____:

I don't think it's revelant to nginx

Well, I switch to the webcron instead of system cron and it works now

image

But I still get some warning from the admin page warn that some tasks has not be executed for 3 days and urge me to switch to the system cron, I really have no idea what it means and what I can do to complete the task it mentioned.

I wonder if I can do something to improve that ? thank you.