Credentials not remembered in client

Every time I reboot, Nextcloud client says “You have been logged out. Please log in again.”

Nextcloud version: 15.0.7
Operating system: Ubuntu Mate 19.04
Nextcloud client: 2.5.2git (build 20190319)

The issue you are facing:
I’ve tried using my main password and creating an app specific password. I can log in and sync. When I reboot, Nextcloud has remembered the server address, but not the password.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. New client install using the .AppImage
  2. Log in
  3. Reboot

The output of your Nextcloud log in Admin > Logging:

|OCC::FolderMan::setupFolders |Setup folders from settings file|
|---|---|
|[OCC::ConfigFile::setupDefaultExcludeFilePaths |Adding user defined ignore list to csync: "/home/edent/.config/Nextcloud/sync-exclude.lst"|
|[OCC::FolderMan::addFolderInternal |Adding folder to Folder Map  OCC::Folder(0x55eed3d2a7a0) "1"|
|[OCC::FolderMan::scheduleFolder |Schedule folder  "1"  to sync!|
|[OCC::FolderMan::scheduleFolder |Folder is not ready to sync, not scheduled!|
|[OCC::ownCloudGui::slotSyncStateChange |Sync state changed for folder  "https://example.com/nextcloud/remote.php/webdav/" :  "Sync Paused"|
|[OCC::SyncJournalDb::checkConnect |sqlite3 version "3.11.0"|
|[OCC::SyncJournalDb::checkConnect |sqlite3 journal_mode= "wal"|
|[OCC::ClientProxy::setupQtProxyFromConfig |Set proxy configuration to use the prefered system proxy for http tcp connections|
|[OCC::WebFlowCredentials::fetchFromKeychain |Fetch from keyhchain!|
|[OCC::AccountState::slotCredentialsFetched |Fetched credentials for "https://example.com/nextcloud" attempting to connect|
|[OCC::WebFlowCredentials::createQNAM |Get QNAM|
|[OCC::ConnectionValidator::systemProxyLookupDone |No system proxy set by OS|
|[OCC::AccessManager::createRequest |2 "" "example.com/nextcloud/status.php" has X-Request-ID "95f15803-9dc8-4979-9346-41833e3eaf63"|
|[OCC::AbstractNetworkJob::start |OCC::CheckServerJob created for "https://example.com/nextcloud" + "status.php" "OCC::ConnectionValidator"|
|[OCC::WebFlowCredentials::slotFinished |request finished|
|[OCC::CheckServerJob::finished |status.php returns:  QJsonDocument({"edition":"","installed":true,"maintenance":false,"needsDbUpgrade":false,"productname":"Nextcloud","version":"15.0.7.0","versionstring":"15.0.7"})   QNetworkReply::NetworkError(NoError)  Reply:  QNetworkReplyHttpImpl(0x55eed4018610)|
|[OCC::ConnectionValidator::slotStatusFound |** Application: ownCloud found:  QUrl("https://example.com/nextcloud")  with version  "15.0.7" ( "15.0.7.0" )|
|[OCC::ConnectionValidator::setAndCheckServerVersion |QUrl("https://example.com/nextcloud") has server version "15.0.7.0"|
|[OCC::AccountState::slotConnectionValidatorResult |AccountState connection status change:  OCC::ConnectionValidator::Status(Undefined) -> OCC::ConnectionValidator::Status(CredentialsNotReady)|
|[OCC::AccountState::slotInvalidCredentials |Invalid credentials for "https://example.com/nextcloud" asking user|

Found someone else with the problem - https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1663831.html

the new client uses qtkeychain, which uses either gnome-keyring or kwallet. I’m
starting gnome-keyring with my login session running Xfce, however the password
is still not saved.

I seem to have gnome-keyring installed, but I still can’t get Nextcloud to save my password.

I gave up and removed the .AppImage version. Installing 2.5.1 using sudo apt install nextcloud-desktop and everything works.

1 Like