Could not update user information

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 29.0.5): 27.0.0
Operating system and version (eg, Ubuntu 29.04): docker image
Apache or nginx version (eg, Apache 2.4.25): no nginx
PHP version (eg, 8.3): 8.2.8

The issue you are facing:

Recently, I found user managment could not update user information. Including email, password or group. Add user is ok, but add group does not working. No error alert. Docker image version is ‘lasest’, pulled about 11 months before ago.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:

NO logging about users

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'htaccess.RewriteBase' => '/',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'apps_paths' => 
  array (
    0 => 
    array (
      'path' => '/var/www/html/apps',
      'url' => '/apps',
      'writable' => false,
    ),
    1 => 
    array (
      'path' => '/var/www/html/custom_apps',
      'url' => '/custom_apps',
      'writable' => true,
    ),
  ),
  'instanceid' => 'ocqsjzqieaz5',
  'passwordsalt' => 'HIDDEN',
  'secret' => 'HIDDEN',
  'trusted_domains' => 
  array (
    0 => 'HIDDEN',
  ),
  'datadirectory' => '/var/www/html/data',
  'dbtype' => 'mysql',
  'version' => '27.0.0.8',
  'overwrite.cli.url' => 'HIDDEN',
  'dbname' => 'nextcloud',
  'dbhost' => 'db',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'HIDDEN',
  'dbpassword' => 'HIDDEN',
  'installed' => true,
  'appstoreenabled' => false,
  'session_lifetime' => 604800,
  'mail_smtpmode' => 'smtp',
  'mail_smtphost' => 'HIDDEN',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'HIDDEN',
  'mail_domain' => 'HIDDEN',
  'mail_smtpport' => '465',
  'mail_smtpsecure' => 'ssl',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'HIDDEN',
  'mail_smtppassword' => 'HIDDEN',
  'updater.secret' => 'HIDDEN',
);

The output of your Apache/nginx/system log in /var/log/____:

No nginx just installed by docker compose 

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

seems no about user error

[webdav] 错误: TypeError: OCA\DAV\Connector\Sabre\Directory::__construct(): Argument #2 ($info) must be of type OCP\Files\FileInfo, bool given, called in /var/www/html/apps/dav/lib/Upload/UploadHome.php on line 93 at <<closure>>

 0. /var/www/html/apps/dav/lib/Upload/UploadHome.php line 93
    OCA\DAV\Connector\Sabre\Directory->__construct(["OC\\Files\\View"], false)
 1. /var/www/html/apps/dav/lib/Upload/UploadHome.php line 57
    OCA\DAV\Upload\UploadHome->impl()
 2. /var/www/html/apps/dav/lib/Upload/UploadHome.php line 67
    OCA\DAV\Upload\UploadHome->getChild("web-file-upload ... 3")
 3. /var/www/html/3rdparty/sabre/dav/lib/DAV/Tree.php line 111
    OCA\DAV\Upload\UploadHome->childExists("web-file-upload ... 3")
 4. /var/www/html/3rdparty/sabre/dav/lib/DAVACL/Plugin.php line 834
    Sabre\DAV\Tree->nodeExists("uploads/1506030 ... 3")
 5. /var/www/html/apps/dav/lib/Connector/Sabre/DavAclPlugin.php line 98
    Sabre\DAVACL\Plugin->beforeMethod(["Sabre\\HTTP\\Request"], ["Sabre\\HTTP\\Response"])
 6. /var/www/html/3rdparty/sabre/event/lib/WildcardEmitterTrait.php line 89
    OCA\DAV\Connector\Sabre\DavAclPlugin->beforeMethod(["Sabre\\HTTP\\Request"], ["Sabre\\HTTP\\Response"])
 7. /var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php line 456
    Sabre\DAV\Server->emit("beforeMethod:MKCOL", [["Sabre\\HTTP\\ ... ]])
 8. /var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php line 253
    Sabre\DAV\Server->invokeMethod(["Sabre\\HTTP\\Request"], ["Sabre\\HTTP\\Response"])
 9. /var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php line 321
    Sabre\DAV\Server->start()
10. /var/www/html/apps/dav/lib/Server.php line 364
    Sabre\DAV\Server->exec()
11. /var/www/html/apps/dav/appinfo/v2/remote.php line 35
    OCA\DAV\Server->exec()
12. /var/www/html/remote.php line 172
    require_once("/var/www/html/a ... p")

MKCOL /remote.php/dav/uploads/15060303/web-file-upload-0ee2fed3ee16fadd2798eea49cc53ffe-1718764866373
from 192.168.9.228 by 15060303 at 2024-06-19T02:41:55+00:00

I found maybe use low version chrome(ver. 78) could modify user information. But add group still not working.