Could not establish connection to the Collabora Online server. This might be due to a missing configuration of your web server. For more information, please visit: Connecting Collabora Online Single Click with Nginx

Hey. I dont know whats wrong, i am using Nextcloud with docker-compose example “fpm mariadb”. I get this error: Could not establish connection to the Collabora Online server. This might be due to a missing configuration of your web server. For more information, please visit: Connecting Collabora Online Single Click with Nginx

I updated to newest version of collabora. Can someone help me?

Hello,
Can you check your nginx conf:

I use Docker. u mean the one in the web folder?

Check this post before


The last update of collabora app broke my install too. Try to update

I updated already.

I have UFW firewall in my server. Which port do i need to enable?

Ufw is ok. You just need port 443
You have set up the built in code server ?
You don’t have nginx conf ?

i have. but its not “serverconfig.conf” like conf.d, its like /etc/nginx/nginx.conf…

Do you have /etc/nginx/sites-available ?
Can you display your nginx.conf ?

It should be like this, i didnt change anything so it must be same as : https://raw.githubusercontent.com/nextcloud/docker/master/.examples/docker-compose/with-nginx-proxy/mariadb/fpm/web/nginx.conf

Should i better open issue ticket on github?

But you didn’t add richdocument context:

location ~ ^\/nextcloud\/(?:index|remote|public|cron|core\/ajax\/update|status|ocs\/v[12]|updater\/.+|oc[ms]-provider\/.+|.+\/richdocumentscode\/proxy)\.php(?:$|\/) {

Hey. Should i add that to the bottom?

This line already exist in your nginx conf but it is not complete. You just have to add the end “richdocumemts…”

yes but thats for built in code server but i always used apache docker before without built in, maybe it is because i dont have overwritehost in config.php?

I did that what u said, still not working.

I wrote the post you cited. I updated and now it works. I have to say that I don’t use Nginx, but Apache

In fact, it was not the same issue.
On one hand, the 3.7.0 collabora app broke installation. So yes, just update collabora worked.

But On the other hand, the built in code server seems not working with nginx

I would like install built in code server on my proper installation (I have nginx too) but my updater doesn’t show me NC19

I switched to apache and still not working. I did set up Onlyoffice with docker the website of my document server said its working, but when i typed the url to the onlyoffice settings it gave me virtualhost error. I hope this will be fixed.

But… what do you talk about ? The topic is about collabora online