"Correct" icons on Linux for Virtual Filesystem files

The issue you are facing:
When VFS is enabled on Linux the users see a lot of files with the filename ending .nextcloud. Due to this the icons for all these files are generic. Is there a solution to show the “real” icon e.g. for .odt show the LibreOffice icon?

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

  1. Setup a fresh Suse Leap
  2. Install the newest Client from the Nextcloud website
  3. Enable experimental features
  4. Login to Nextcloud server and map a share with VFS enabled