Content of subfolders dont get uploaded

Hi!
I just installed the windows client 2.5.1.
i’m using windows 7
I moved some files and folders to my Nextcloud folder.
First i thougt everything was fine because the files started syncing, but now i realize, that all the files in subfolders of folders dont sync.
Example
“Nextcloud/file.txt” gets synced
“Nexcloud/folder/file.txt” gets synced
“Nextcloud/folder/subfolder” gets synced
“Nextcloud/folder/subfolder/file.txt” does NOT get synced
“Nextcloud/folder/subfolder/subsubfolder” does NOT get synced
The files dont appear in the cloud if i check in my browser, neither in my android app. Neither they have that little green checkmark.
Any idea what goes wrong?

1 Like

Have you checked the sync client of synching for this particular subfolder is enabled?

Thanks, i didn’t change anything, but the next day it worked like it should!

That is misleading you. Out of my experience it will come back.
My observation:
If I create a new subfolder it will be synced.
If I put a file in the new subfolder this file will not be synced.

If you stop and start the Nextcloud-client syncing will be fine.

Okay, thx for info! Restarting the Client seems like an accaptable workaround.

I do not agree that restarting the client is an acceptable workaround. There’s a bug open for this:

Please feel free to leave a comment there, maybe we can get somebody’s attention and get this fixed.

2 Likes

cannot believe that such a major bug is not fixed for months at least? still not fixed today. it’s now really scary to use such a cloud software that does not sync!

1 Like

same here as thread-opener says.
When I copy a folder with subfolders into my nextcloud-folder (Windows), it syncs the folders but NOT the files inside. On the server (linux, newest versions of all) all subfolders are empty UNTIL I restart my client (windows, newest version). very annoying…
A sync-Software which doesnt sync???
like a beer without alc…

1 Like

I can confirm this bug with client 2.5.2 on a Linux Mint 19 system. Also the workaround by restarting the client works, but this is not acceptable. How is it possible such a major bug is not solved after this long time? It seems to be fixed in 2.5.3, when will that be released?

If you read through the linked github issue you may find, that this will be fixed in client version 2.5.3:

There’s also a link to a testing client which includes the fix…if someone is eager enough to help testing the fix.