Contacts via CalDav to FritzBox don't work with 2fa activated

If I activate 2fa, I’m not able anymore to access the Contacts from NextCloud via FritzBox Contacts (choosed CardDav).

I’d created the app-related Password like described here: Verwalten Sie verbundene Browser und Geräte — Nextcloud latest User Manual latest Dokumentation

If I deactivate 2fa I can access the nextcloud contacts again - with the app-related password I’ve set for it.

I’m using 2FA with my standard account too and don’t have any issues access CalDAV/CardDAV data via an app specific password. You need to provide more detailed information about what exactly happens if you try to access it, like e.g. providing the link you’re using, log entries etc., ewtc.

BTW you should change the subject of this post, because contacts can only be accessed using CardDAV and not CalDAV :wink:

Hello,

I have got the same problem. On other accounts i. e. multiple DAVx5 it works out of the box with generated tokens. Also multiple Thunderbird setups works with no problems. With my Fritzbox I get an 401/Unauthorized response.

I am using a self hosted Nextcloud with Authelia 2FA enabled. Fritzbox 7590 is on current Firmware 7.57.

In the Nextcloud Web UI I created a new Token and copied it. In FritzBox web UI I created a new caldav phonebook with my URL: https://cloud.mydomain.com/remote.php/dav/addressbooks/users/johndoe/contacts/ .
Username is johndoe and as password I use the created token.

If I click sync I always get the message “Please check your login credentials”.

What I am doing wrong?

Have you ever tried to login to Nextcloud with the created account and token before you use it in your Fritzbox?

I tried it before with a new Thunderbird profile and there it works immediately without any issues.
Conversely, I also tried it with my currently working Thunderbird data and it doesn’t work either.
Normal log-in does not work with either of them.