Contacts search issue (Cannot open results), NC20.0.3 RC1

By and large the full text search function works/has worked well for me in the past. I have issues with the Calendar not finding all entries and sometimes no future entries which is odd but I’m sure we’ll get there :slight_smile:
After the most recent update to NC20 (.0.3 RC1) I think the following behaviour started although I am not 100% sure about this so apologies.
If I search for a contact in the search box the contacts all appear as expected but, when I select the contact I want I am not taken to that contact, i.e. it does not open and I am left on a blank white screen for ever.
Here is a screen capture of the issue:
Probably some silly setup issue because surely this would have been noticed by others :slight_smile:


Hello James,

have you checked issues at GitHub?

With v20.0.2 it works here.

btw. your cloud needs an performance update :grin: You viewed your video and it took me around a minute to load it :sloth:

1 Like

I think this is a known issue which is already being worked on and which happens if an address book name contains a white space, e.g. “All contacts”.

1 Like

Yes, I did check for issues before I posted but didn’t find any however, it seems I missed the pre existing issue mentioned below so nil point for research :confused:
ON the subject of server performance had you considered perhaps that there are still people on ADSL MAX :smile:
My upstream bandwidth is, currently, 344 kbps therefore this is the bottleneck you are experiencing. It’s also the reason why I made the video so smaaaaal :wink:
Obviously this is not a production server but merely a personal experiment. I can retrieve personal files and upload pictures (my downstream is around 6Mbps) but it’s a non starter for service large files out the way.
I’m hopeful that we will be upgraded one day but, for now, that’s just how things are.
Thanks for getting in touch and testing my connection for me though :wink:

Hi j-ed,
I did search but didn’t see this. However, I don’t think this is my issue to be honest? The thing is that this behaviour is new and that bug has been around for a while. What I am trying to do used to work, quite recently. I have only noticed this behaviour in the last few days (week?) so I attributed it to the latest upgrade.
I am not trying to share anything just search for and open a contact entry?
Thanks for the input though, perhaps I am misunderstanding the post you linked me to.

Ahha! I looked further down that conversation and found this:

This one definitiely describes my problem and is more current. Just took a little digging which, clearly, I am not great at :slightly_frowning_face:
I’ll keep an eye on this one then thanks so much

My condolences :dark_sunglasses:

Just kidding. After moving to our old new house we didn’t had internet connection at all for about 3 month. Couldn’t remember how we did survive this deprivation :grin:

1 Like

Ok, so I received an update to NC20 today, we are on 20.0.3 RC2
I wondered if perhaps the contacts search problem had been addressed and updated the server to test.
Sadly, not for me and now I get this:

Internal Server Error
The server was unable to complete your request.

If this happens again, please send the technical details below to the server administrator.

More details can be found in the server log.

Technical details
Remote Address:
Request ID: 0lTAAigKSMONGxLKzmei

Can anyone shed light on this or, alternatively, tell me what I do with that Request ID?



Due to the fact that you’ve installed a release candidate you most likely have to fix your problems on your own :wink: As written in the displayed error message, check the Nextcloud log file for any error message which lead you to the root cause of the problem.

Ahh well, that’s that then :wink:
I already did check the logs and didn’t see anything of any note…but then again, would I understand what I was looking at this is the real question :grinning:
I’ll have another look .
Other search items work although, I’m pretty sure the Calendar doesn’t actually find all instances of any given search but that’s another issue for another day.

Ahaa. I see the Reqest ID’s are in the log file so, I did a search for my own contact details in my file and got a new error which goes like this:

{“reqId”:“2POC3pXQVuf1wqAouaEH”,“level”:1,“time”:“2020-12-09T17:59:01+00:00”,“remoteAddr”:“”,“user”:“james”,“app”:“no app in context”,“method”:“G
eNotFoundException”,“Message”:“Unable to generate a URL for the named route “” as such route does not exist.”,“Code”:0,“Trace”:[{“file”:"
okmarks/vendor/symfony/routing/Generator/UrlGenerator.php",“Line”:143,“CustomMessage”:"–"},“userAgent”:“Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36
(KHTML, like Gecko) Chrome/86.0.4240.183 Safari/537.36 OPR/72.0.3815.320”,“version”:“”}

That’s pretty much gobbledy gook to me but if some bright person were to point me in the direction of a possible fix or, even better, tell me it’s not something I’ve done, this would be a good thing


Im getting this with latest 20 version. contacts version 3.4.2
i see there is an issue when clicking on the link the relevant search is found but when clicked the browser removes the index.php from the root of the server path. If I put it back in the relevant contact appears. I have no idea how to fix this.

Hi James,
Looks like you diagnosed the issue :slight_smile:
I wasn’t even smart enough to do that but, it seems, the problem has now been resolved…for me at least.
Contacts 3.4.3
NC 20.0.4

Thanks to whoever cleared this bug.


1 Like

Can I ion thatv I am now experiencing this exact issue using the calendar search. I search in universal search, click on a result from the calendar and am taken to the calendar app where an oblong dialogue with a right facing arrow is open overlaying the main calendar. I expect the entry in question should appear here but it never does.
Perhaps I should open a new question for this?


1 Like