Contact search display error

Support intro:

Nextcloud version (20.0.4):
Operating system and version (Ubuntu 18.04.4):
Apache or nginx version ( Apache 2.4.29):
PHP version (7.4.7):

The issue I’m facing:

The dropdown menu for contacts (right side) is not correct diplayed. (see picture)

grafik

The picture and the icons for email and Talk are shown incorrect.
I rebooted the system without improvement

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => '*****',
  'passwordsalt' => '*****',
  'secret' => '****',
  'trusted_domains' => 
  array (
    0 => 'cloud.****.de',
  ),
  'trusted_proxies' => 
  array (
    0 => '192.168.178.98',
  ),
  'datadirectory' => '/mnt/hdd/data',
  'dbtype' => 'mysql',
  'version' => '20.0.4.0',
  'overwrite.cli.url' => 'http://cloud.*****.de',
  'dbname' => '*****',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '*****',
  'dbpassword' => '*****',
  'installed' => true,
  'theme' => '',
  'loglevel' => 2,
  'maintenance' => false,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'mail_from_address' => 'cloudmaster',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => '****.de',
  'mail_smtpauth' => 1,
  'mail_smtphost' => '*****',
  'mail_smtpport' => '25',
  'mail_smtpname' => '*****',
  'mail_smtppassword' => '*****',
  'app_install_overwrite' =>
   array (
    0 => 'mindmap_app',
  ),
);
1 Like

I have the same issue,… in my case an official docker instance (latest) on de debian host behind an nginx reverse proxy.

Hi there,

I happend to solve this by accident. After installing OnlyOffice I got a “Unknown error” when open OnlyOffice document in Nextcloud. See "Unknown error" when open OnlyOffice document in Nextcloud 18 · Issue #975 · nextcloud/docker · GitHub

I issued the command below to set the overwriteprotocol

docker-compose exec --user www-data app php occ config:system:set overwriteprotocol --value=“https”

It fixed my OnlyOffice problem and also the broken contact display (at least that’s what I think).

Best regards, JBR

I had this same issue running Nextcloud via snap. my command was a bit different. I hope someone finds it useful.

nextcloud.occ config:system:set overwriteprotocol --value=“https”

Thank you for this!