Connexion Nextcloud to external Openldap does not works

Hello
I just install a fres nextcloud with lates version 23.0.3 on a Ubuntu 20.04 VM.
I have a openldap working on another Ubuntu VM and works fine with a Owncloud connected on it.

I have activate the “Integration LDAP / AD” app on nexcloud.
But when going to the parameter of this app, everythings seems in “grey” (like tabs user, login attribut, groups, advance, expert)
I try to fill the host, port, DN user, password, base but when selecting the button “test DN base” nothing append…
No log in “nextcloud/data/nextcloud.log”

And the command :

ldapsearch -x -b “dc=mydomain,dc=net” -H ldap://ldap.mydomain.net:389 -D “cn=admin,dc=mydomain,dc=net” -W

works fine

any idea of the problem?

Some more information on my probleme…

1 perform 2 new VM with the folowwing conf :

The "manual install has the “Integration LDAP / AD” app error describe in my above post.
The “nextcloud_install_production.sh” works…
=> so 1rst conclusion the ldap and networks works fine :wink:

I guess it is a package (ubuntu) ou app (nextcloud) or conf (nextcloud issue) ?

I have install the package I have seen in the “nextcloud_install_production.sh” but without any change

Any idee?

PS : I wish not use the VM with the “nextcloud_install_production.sh” due to aache choice and I prefer nginx :wink:

Glad to hear that the installation script works! It makes the whole process (and maintainance) so much easier!

Regarding the choice of Apache, there are several reasons for that. Once being that Nextcloud isn’t a static website, and that’s that Nginx are best suited for. Apache are better at serving changed content such as files in your cloud.

Yes your script works fine :slightly_smiling_face:
But as I am trying to improve myself in the ldap centrilise password, I prefer to do it manualy…

Did apache much better than nginx for a small nextcloud server with few user (max 10…) ?

And as you should be fully aware of how ldap integration works, did you have any idea where I can search to resolve my error ? or which log to watch to go forward?

I have check your scrip for package and app but without any success !

Many thanks