Connectivity errors with nonstandard ports

It works now :mushroom:
I’ll take a look later as I’ve only got notepad on this laptop and it’s not a pretty experience going through logs.

Hi Jason, thanks. I have just activate the links for 2 or 3 days. And also, it was done via nano (I am still new on Linux) and No, notepad doesnt work… not even GEDIT!

And if you need the whole log, please let me know and I will email it to you instead. I ma just a bit concerned about security. And just out of the interests . I am using Apache2 with Nextcloud (as most sites recommended with standard setup). I have set up the different listening port before but Nextcloud behaved intermittent when using Android application (I can log in some times and I cannot via Android App) even though the secure connection is working (using HTTPS). Is there a bug around this issue if changing to different ports? i.e. changing listening port to 56666 under ports.conf, apache2.conf ./sites-avaible/000-default.comf default-ssl.conf and nextcloud.conf ? SSL port remains 443 and UFW opens for ports 56666 as well as router firewall forward from 56666 to 443? It really gives me connectivity issues / login issues from time to time which I failed to understand. I have also remove the app / clear data and cache on the Android phone…

It is now working 100% with standard 80 and 443 port however!

{"reqId":"K0EV3sEzmt3r7tO9b2Yc","remoteAddr":"","app":"core","message":"Trusted domain error. \"\" tried to access using \"\" as host.","level":2,"time":"2017-02-01T12:28:43+00:00","method":"GET","url":"\/nextcloud\/status.php","user":"--","version":""}

That’s fine, it happens if the domain or IP you’re coming from isn’t approved in your config file.

{"reqId":"mb10Yxrvk7QGEU16iSx7","remoteAddr":"","app":"files","message":"initMountPoints() called with wrong user casing. This could be a bug. Expected: \"IamChefBoyct1978\" got \"IamChefboyct1978\". Stack: [{\"file\":\"\\\/var\\\/www\\\/nextcloud\\\/lib\\\/private\\\/Files\\\/Filesystem.php\",\"line\":375,\"function\":\"initMountPoints\",\"class\":\"OC\\\\Files\\\\Filesystem\",\"type\":\"::\"},{\"file\":\"\\\/var\\\/www\\\/nextcloud\\\/lib\\\/private\\\/legacy\\\/util.php\",\"line\":235,\"function\":\"init\",\"class\":\"OC\\\\Files\\\\Filesystem\",\"type\":\"::\"},{\"file\":\"\\\/var\\\/www\\\/nextcloud\\\/apps\\\/provisioning_api\\\/lib\\\/Controller\\\/UsersController.php\",\"line\":634,\"function\":\"setupFS\",\"class\":\"OC_Util\",\"type\":\"::\"},{\"file\":\"\\\/var\\\/www\\\/nextcloud\\\/apps\\\/provisioning_api\\\/lib\\\/Controller\\\/UsersController.php\",\"line\":213,\"function\":\"fillStorageInfo\",\"class\":\"OCA\\\\Provisioning_API\\\\Controller\\\\UsersController\",\"type\":\"->\"},{\"function\":\"getUser\",\"class\":\"OCA\\\\Provisioning_API\\\\Controller\\\\UsersController\",\"type\":\"->\"},{\"file\":\"\\\/var\\\/www\\\/nextcloud\\\/lib\\\/private\\\/AppFramework\\\/Http\\\/Dispatcher.php\",\"line\":160,\"function\":\"call_user_func_array\"},{\"file\":\"\\\/var\\\/www\\\/nextcloud\\\/lib\\\/private\\\/AppFramework\\\/Http\\\/Dispatcher.php\",\"line\":90,\"function\":\"executeController\",\"class\":\"OC\\\\AppFramework\\\\Http\\\\Dispatcher\",\"type\":\"->\"},{\"file\":\"\\\/var\\\/www\\\/nextcloud\\\/lib\\\/private\\\/AppFramework\\\/App.php\",\"line\":114,\"function\":\"dispatch\",\"class\":\"OC\\\\AppFramework\\\\Http\\\\Dispatcher\",\"type\":\"->\"},{\"file\":\"\\\/var\\\/www\\\/nextcloud\\\/lib\\\/private\\\/AppFramework\\\/Routing\\\/RouteActionHandler.php\",\"line\":47,\"function\":\"main\",\"class\":\"OC\\\\AppFramework\\\\App\",\"type\":\"::\"},{\"function\":\"__invoke\",\"class\":\"OC\\\\AppFramework\\\\Routing\\\\RouteActionHandler\",\"type\":\"->\"},{\"file\":\"\\\/var\\\/www\\\/nextcloud\\\/lib\\\/private\\\/Route\\\/Router.php\",\"line\":299,\"function\":\"call_user_func\"},{\"file\":\"\\\/var\\\/www\\\/nextcloud\\\/ocs\\\/v1.php\",\"line\":79,\"function\":\"match\",\"class\":\"OC\\\\Route\\\\Router\",\"type\":\"->\"}]","level":2,"time":"2017-02-02T10:29:26+00:00","method":"GET","url":"\/nextcloud\/ocs\/v1.php\/cloud\/users\/IamChefboyct1978?format=json","user":"IamChefBoyct1978","version":""}

How are you mounting the data? Is it local or on external media?

Ports I can’t really comment on, it could be a few things. Maybe setup a test environment on those ports again and we can troubleshoot.

Hi Jason,

Thansk for getting back to me so quickly. so is the server (which is 24/7 on and on a Dell laptop). And is the mobile phone which is accessing and updating these files.

and Nextcloud server data is sitting on an “External HDD” which has 400GB allocated to it. Unfortunately I have 2 x SSD which are 120 / 240GB each and one is for Windows and one is for Zorin (Ubuntu). But the External HDD (partition) is also mounted via FSTAB/dev/disk/by-label/Nextcloud\134x20Server /media/chefboyct/nextcloud_data auto nosuid,nodev,nofail 0 0
and it has two partition on it (both EXT4). I hope this explained what you are asking. So would it make any difference if it is sitting on external HDD and what will be the correct way to fix it?


This actually looks like it could be related to:

In which case it’s not causing problems, just an FYI.

Hi Jason.

So what you are saying is that even though I am getting notification and error message in the log file, it actually doesn’t mean anything? So I should just ignore it?



Well I hoped you’d read the attached issue but yes it is just a warning due to there being a difference between letter case.