Connection to Nextcloud incredibly slow after Update to Android 7.0 (Nougat)

Today I updated my Oneplus 3 to Android 7.0 (Nougat). Everything seems to work smoothly beside connections to my Nextcloud server. It is extremely slow. Apps that are connected to my server are

  • Nextcloud App
  • DAVdroid
  • Foldersync

The Nextcloud App needs a long time to get the folder update. DAVdroid als needs a long time to sync and to fetch calendar data when I open the DAVdroid app directly.

The Foldersync app which actually should sync three folder pairs to my cloud, fails completely. When I check the account settings and test them, I get “Unauthorized” after a certain time.

I did not change any settings of those apps since they have been working perfectly before. I tried to re-install Foldersync and re-adding the complete data, but without success.

Since I am experiencing this on three independent apps, I think that it might be an Android issue. I tried connecting through http and https.

Is this behaviour known? Any input is welcome…

Some more information after some hours of frustration.

My wife has the same issue with her mobile and Android 6.x. Meanwhile I think this issue is related to some DAV connection problem since I get some fatal errors for a user in webdav. There an event issue on a calendar is mentioned. This is already occruing for more than ten days.

However with the update to Android 7.0 on my Oneplus 3 it seemed to be broken since I cannot access webdav or cal/carddav anymore.

Now all my Windows Nextcloud clients (2 users) aren’t able to connect anymore.

However, connecting via the web interface works but logging in takes longer than normal.

No external sync session is succeeding, meither to Android nor to Windows…

Did somebody experience comparable behaviour? I believe that I have something similar going on as desrcibed here:

Please check your logfiles. What did you change on the server? Any updates, restarts, …? Something broken (full hard disk, runs out of memory, … -> check system logs).

I did check everything (including all the logs) and restarted the Apache Webserver as well as the MySQL service on my vServer. There was no immediate effect.

All of a sudden, the problem disappeared this afternoon, roughly an hour after I restarted the services on the server. In the end, I am happy that the problem disappeared. However, I want to be able to explain what happened.

I do believe that my vServer provider was experiencing some issues at the same time I was updating some devices. I am not able to link the update above with the DAV issues.