Connection doesn't work on port 80 - blocked by ISP?


#1

I can access my server fine through a port like 880, but not through port 80. Does this mean that my ISP is blocking that port? Is there some other factor that I might have missed.

Is there a good tutorial for self-signed SSL certificates and how to install it, if my ISP is blocking port 80?

Running Ubuntu Server 16.04
Installed Nextcloud 12 with snap

Thank you!


#2

Hi,

I assume you setup port forwarding on your router for port 80 to your server (probably running on port 80 as well). Is this correct?
If so, please check if the the web interface of your router is also available on port 80.

I had that issue with port 443 for HTTPS and had to change the default port for the router’s web interface to a different port. Just an idea.


#3

How do i check that? Thank you


#4

So it is about port forwarding?

What router do you have? You would check that via the web GUI of your router and look for port settings in the router config. At least on a Fritz!Box you can define the port the web gui is reachable on.

Further details are necessary however. Please answer the following questions:

  • what is your ISP?
  • what router are you using?
  • what are your current port forwarding settings on your router?
  • is your external IP address an IPv4 address (the address your ddns name is pointing to)?
  • can you reach your router’s web gui via port 80 and 443?

#5

Hi! Thank you for you help but i solved the issue. The port forwarding wasn’t the way to do it, but apparently i needed to use a feature called ‘virtual server’ and that made it work!


#6

Hi, @Fredrik_Burmester could you please share any tutorials / resources you used to resolve the ussue.
I am stuck at the same place.
Thanks in advance.


#7

Hi! My router was acting up or something. The only this you should need to do is to forward the port 80 in your router to the exact ip of the device you want to access. If you’re trying to self-sign a certificate with letsencrypt, make sure that nothing else is running on port 80 and no other port forwarding rules for port 80 is set up EXCEPT for the device you are trying to access with port 80.


#8

Ok, I thought your ISP was blocking port 80. That seems to be my issue.