"Connection closed" message when syncing files larger than 500 MB

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version 24.0.6
Operating system and version (eg, Ubuntu 20.04): Ubuntu 22.04
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.52 (Ubuntu)
PHP version (eg, 7.4): PHP Version 8.1.2

The issue you are facing:
Uploading file with size over 2 GB via web is no problem but whenever i try to sync the same file using the windows sync client i receive a “Connection Closed” and client goes offline.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Sync folder that has file with size over 1 GB

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'oc7x8b3bihwz',
  'passwordsalt' => 'xxx',
  'secret' => 'xxx',
  'trusted_domains' => 
  array (
    0 => '',
  'datadirectory' => '/var/www/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => 'mypassword',
  'installed' => true,
  'activity_expire_days' => 3650,
  'default_phone_region' => 'ID',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => 'true',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => 0,
    'timeout' => 0.0,
  'app_install_overwrite' => 
  array (
    0 => 'issuetemplate',

The output of your Apache/nginx/system log in /var/log/____:

[Fri Oct 14 02:56:38.339505 2022] [proxy_fcgi:error] [pid 23655:tid 140516939937344] (70008)Partial results are valid but processing is incomplete: [client] AH01075: Error dispatching request to : (reading input brigade)
[Fri Oct 14 02:56:47.910669 2022] [proxy_fcgi:error] [pid 23655:tid 140516931544640] (70007)The timeout specified has expired: [client] AH01075: Error dispatching request to : (reading input brigade)
[Fri Oct 14 04:23:55.349069 2022] [access_compat:error] [pid 24438:tid 140564708173376] [client] AH01797: client denied by server configuration: /var/www/nextcloud/data/.ocdata
[Fri Oct 14 05:51:03.446194 2022] [proxy_fcgi:error] [pid 24438:tid 140565152790080] (70007)The timeout specified has expired: [client] AH01075: Error dispatching request to : (reading input brigade)
[Fri Oct 14 05:51:03.550389 2022] [proxy_fcgi:error] [pid 24439:tid 140564666242624] (70007)The timeout specified has expired: [client] AH01075: Error dispatching request to : (reading input brigade)
[Fri Oct 14 06:26:17.088624 2022] [access_compat:error] [pid 24438:tid 140565144397376] [client] AH01797: client denied by server configuration: /var/www/nextcloud/data/.ocdata

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

No log entry has produce

Please check /etc/php/apache/php.ini
In this file the file size limit is set.

If runnung in Docker etc. check there the same file in the container.

Hi Morngrans,

I have put this in php.ini

memory_limit = 512M
upload_max_filesize = 6G
post_max_size = 6G
max_execution_time = 300

As I can upload that big file via web client.

I can successfully sync a 2.7 GB file from windows client to NC server, but I am getting error when sync that same file from NC server to windows client.

Concerning to your PM I can see your both postings.
If files or folders ecxeed a special size, you must permit download in the settings of your Nextcloud client software in the dialog, where you can de-/select folders to be synchronized…

Yes I know I can deselect the folder, is that 2 GB file special size?
Why user can sync large file more than 2 GB from windows client to server but can not sync it back from server to windows client?

You can set the size in the settings of your desktop client:

Confirm, before folders become synchronized. Limit xx MByte

There is a check mark at the Ask for confirmation before synchronizing folders larger than 500 MB