Connecting Server to the internet

Hi everyone

This is my first venture into servers, but I found an old PC and I thought it would be a good use. So far I’ve installed Ubuntu Server (command line version) with Nextcloud and its working great as an LAN server. I’ve been trying to connect it to the internet so I ca access the content wherever I am. I’ve tried port forwarding on the IP address (ports 80-430 I believe) and adding the op address to the DMZ of my router but without success. Any tips are appreciated!

I think the most important tip is, to explain how your network environment looks like in detail :wink: (BTW, port 80/tcp is for unencrypted http traffic, 443/tcp for ssl secured https traffic)

  • Have you used the search function in the upper right corner to search for similar requests?

  • Which router are you exactly using?

  • What server os version are you using?

  • Which web server, php version, nextcloud version are you using?

  • How are you running Nextcloud, in a container, directly installed, etc.?

  • How have you exactly tested the access and what messages are displayed in the browser?

  • Have you found any related messages in the router and web server log files?

Thank you for your response!

I’ve tried several ways but none se to be working.

I’m using a Netgear SuperHub 2ac. I’m using Nextcloud 14.0.14 (command line one), directly installed onto an old Dell studio Hybrid. I’ve tested it at home on my phone by using cellular data but it never seems to work. The site never seems to connect. It just loads and loads but never goes through.

So back to the list of questions. I think you’ve answered two of them. What about the other questions?

  • Which router are you exactly using?
    => Netgear SuperHub 2ac
  • What server os version are you using?
  • Which web server, php version, nextcloud version are you using?
  • How are you running Nextcloud, in a container, directly installed, etc.?
    => directly installed Nextcloud 14.0.14 (UNSUPPORTED!!)
  • How have you exactly tested the access and what messages are displayed in the browser?
  • Have you found any related messages in the router and web server log files?

Oh, I thought 14.0.14 was the server OS. Sorry! When I try to connect to it through the browser over data it never loads, the progress bar sits, maybe a third of the way over and doesn’t move anymore, eventually displaying “server not responding” message. I’m ashamed to say I haven’t checked the log files, this is my first foray into Linux in general, never mind servers! I did forward a port on my router to ports 80-443 on the server IP but when checked on here it shows up as closed.

I hope these answers help! Sorry!