Connect to Nextcloud Office suddenly stopped working


the connection to my built-in collabra suddenly stopped working, while it was perfectly working before.

The error in the web interface says:

Failed to connect to the remote server: cURL error 60: SSL certificate problem: self-signed certificate

I am using a self-signed cert from letsencrypt. Setting is set to use the integrated CODE-server. And it worked some time perfectly. No changes to my Apache config was done.

System details:

  • Ubuntu 22.04
  • Apache 2.4.52-1ubuntu4.10
  • Nextcloud: Nextcloud Hub 8 (29.0.3)

I also get the information that I cannot connect to my own server, but I got my URL in nextcloud config as “trusted_domain”.

Can somebody please assist me in finding the cause? I am not aware where to search for it, so if there are more details needed, please let me know.

hi @Michael_Herber :handshake:

you are missing the required support template. Please fill this form out and edit into your post. This will give us the technical info and logs needed to help you in case the machine in question in spitting out errors! Since you’ve provided zero technical details it is impossible to help you as-is. Thanks.

indicates you are not using valid public certificate.

such thing does not exist. Either it is self-signed or it comes from letsencrypt

Collabora integration might help with troubleshooting. But I would focus on the self-signed problem first.

1 Like

Hello there,

thanks for the reply.
As I got some further errors shown in admin interface, I also took care of them. One of them was that my server could not connect to itself. I got this solved by adding my hostname to in /etc/hosts.

Strangely, after this, my problem of this post was also solved. Although the connection to the integrated CODE may be connected to this, I am suprised that this solved it, as the reverse proxy config was not changed.

Anyhow, this is solved for me.