Completely locked out by App LDAP User and group backend

Hello everybody,

we are currently testing NextCloud provided by one of our cloud-providers as a managed instance.
It is NextCloud 20 and I do only have access to the Backend / Web-UI, so no local SSH access.

Everything is still a testing-enviroment, so no live data.

This is working fine so far. However, I ran into a serious problem.
I would like to use LDAP authentication for my users.
For this I activated the included - but deactive - app “LDAP user and group backend”

I then configured the settings. In the first step I was able to connect to my LDAP server, connection check worked. Then I wanted to proceed to defining the groups and the other stuff.
However, somewhere along the way, I have been completely locked out of NextCloud and after that I was not able to login back again.

Even the local Admin or other local users I tried did not work.

As I have no direct access to the machine itself, I contacted the provider,
which told me, that LDAP auth fails with error:

Configuration Error (prefix s01): No LD AP Login Filter given!

The provider deactivated the “LDAP user and group backend” app and after that I was able to login again with local Admin and all other users (local).

After that I tried again to configure the LDAP auth, because this is a requirement for us.
As soon as I reactivated the app, I got imediately locked out again. So there must be some wrong config leftover from my first try.

So I have two questions:

  • where are the config files for LDAP user and group backend located. Which files must be deleted to get a fresh start again

  • is it really “by design” that after activating the app, a login with a local user, like local Admin, is not possible any more? Or is this fact only due to misconfiguration by me?

Thanks in advance