Command Line Updater does ...nothing. Help?

update_problems

#1

I’m on 12.0.4 and I know 13 is stable. My upgrade choked and I thought I could use oc upgrade to run it, but I’m getting “Nextcloud is already latest version”:

[0 abh@andy owncloud]$ ./occ upgrade -v
Nextcloud is already latest version

The occ instructions say “These commands are available only after you have downloaded upgraded packages or tar archives, and before you complete the upgrade.” but I’m not sure what that means – I downloaded nextcloud-13.0.0.zip – it’s in my main Nextcloud directory – and I still see Nextcloud is already latest version – tried moving it to my data directory and got the same thing.

Reading this I realized I probably want to start with php updater/updater.phar but when I run that absolutely nothing happens. I get a new command prompt instantly and there’s zero other indication that I did anything.

I’d really like to get this upgrade done, and I’d love any help!


#2

You need to unpack the downloaded nextcloud-13.0.0.zip on the same folder level as your nextcloud-installation and then follow these instructions here:
https://docs.nextcloud.com/server/13/admin_manual/maintenance/manual_upgrade.html#


#3

I also run dreamhost and have had a terrible time getting any of the upgrades to ever work. Continually fails on backup. Would love to figure it out to not have to go through the hard upgrade process. My local copy on a 12 year old netbook runs perfectly however - lol


#4

With a shared hosting, we dont have access to sudo so i’ve never been able to get this to work. I’ve always just done a full reinstall which is a monumental pain in the arse.


#5

Well. That’s not what I wanted to hear, but it’s good to know.

I have been running on Dreamhost since a fairly early version of Owncloud and this is the first time I’ve had this issue with the backup, though I think that until I migrated from Owncloud 8 to Nextcloud 11 in single afternoon of updates, I’d always done what you call the “hard update”. So I guess that’s next.


#6

OK - well good news. I played with the manual steps and figured out that we already have ‘su’ privileges for our directories. As such, I just extracted the new zip file over the top of the old file and manually ran the command “php occ upgrade” and it worked. I only have me as a user to already had my data downloaded to a few clients. I did also copy my config.php file but didn’t need it. Again, this was just me so it’s an easy ‘clean install’ if all went wrong but i’m very excited that I have an upgrade path to work. GL