Collabra - Failed to load Collabora Online - please try again later

@Sanook – Can you post exactly what worked for you and detail the steps? A lot of people including me have this problem and if the resolution could be documented appropriately it would help a lot.


More info please and thank you
Im a bit of a newbe and need some detail, Thank you in advance

Finally i got it working!!! here is what i did remove docker container restart docker redo docker code docker run -t -d -p []:9980 -e ‘domain=cloud\.nextcloud\.com’ --restart always --cap-add MKNOD collabora/code Go into nextcloud , Disable Collabora onine, Re download and enable Collabora online again go to settings in nextcloud, set domain back up (Do not put in the port 8890) go into collabora1 conf file and remove and retype domain name <VirtualHost *:443> ServerName []
Save file
do sudo systemctl reload apache2
do sudo restart apache2,
systemctl restart docker
also im using Pfsense for my firewall and router and put it into True NAT mode.
Im not sure if that was part of the issue but im including it anyway
Tested and its working!!!

1 Like

@sdeskgeo Many thanks for posting your findings and solution. I found that by removing and reinstalling the docker container and the nextcloud collabora app in nextcloud as you suggest, and adding the :443 to the ServerName in apache conf did the trick for me too…and of course the reloading and restarting of apache as it did not take effect until then. And in case anyone wants to know, I used the suggested default directions for nextcloud15 as found in the admin manual, default settings for docker, and default settings from the nextcloud/collabora page…all on a Mint19.1 OS. One more thought, don’t enter a port in the nextcloud/collabora app settings. Hope this confirms and clarifies sdeskgeo’s findings for others.

Hello sdeskgeo,

Can you please elaborate more on your pf sense 1:1 or true nat setup? I am having same exact issue yet everything seems to be set correctly. I am left to blaming it on pf sense.

Thanks in advance. I am extremely excited to try out collabora.

Just an FYI for folks researching the same error. Had the “failed to load please try again later” error. I could create docs but not edit any. I went into Settings>Collabora Online and removed the port number from the server address, applied changes and could edit docs no problem after that. I’d give it a try before reinstalling/reconfiguring anything.

What worked for me was changing all instances of the loopback address in the collabra Apache virtualhost file to the domain of the nextcloud server e.g changed to” being whatever the url of your nextcloud server is.

What I’m wonering is whether there are any security implications for doing this. I assume no traffic will go out onto the net anyway since my collabra docker instance and my nextcloud instance are on the same machine.