Collabra - Failed to load Collabora Online - please try again later

Hi,

I just installed Nextcloud 15.0.4.on a completely fresh Ubuntu 18.04 server. I created a few groups and users and then installed and activated Collabra. Although it allows me to create new documents, I can not open them. When I try, I get the message

Failed to load Collabora Online - please try again later

I don’t have the foggiest idea how to approach this problem and appreciate some help. I am happy to provide any information necessary, if I know what’s needed.

Thanks in advance.

Regards,
Pieter-Jan de Vries

Hi Pieter-Jan,

Reading your message, it seems that you only installed and activated the Collabora Online app in nextcloud.
If that’s it, then you also need to install a Collabora Online server.
The basic instructions are here:

Hi M,

Thanks for the swift reply. And spot on, because I did not realize that I also have to install Collabra Online Server. I’ll give that a try and report back with the results.

Regards,
Pieter-Jan

Apparently it’s not that easy peasy lemon squeezy. I installed Collabora. The native CODE packages, because my VPS setup does not support docker properly. I followed the blog post Running Collabora Online Development Edition without Docker and changed ‘localhost’ in the loolwsd.xml file into my Nextcloud domain. Unfortunately I still get the same error.

Judging the name ‘mjanssens’ I guess you’re Dutch. Is it possible to have voice contact about this issue?

Regards,
Pieter-Jan

I suggest that you discard the buggy Collabora app 3.2.1 of Nextcloud and use the nigntly 3.0.0

Hi peteman52,

Thanks for your input. But I’m curious. Why would someone prefer the 3.0.0 - nightly (Unstable) over the presumed stable and quite newer 3.2.1 version?

Regards,
Pieter-Jan

To change the app solved my problems and I had the message “Failed to load Collabora Online - please try again later” too. And I lost many (to many) hours to find an error in my setup.

Makes sense :smile: But it brings me to the next hurdle: how do I install that nightly build? I read somewhere that I should download and extract it in the apps directory, which I did. I should then click install, but I can not find the app. Can you point me in the right direction?

In your app directory there should be an directory “richdocuments”. You should look which user/group the other directories in your app directory have e.g www-data/www-data.
Then do a
“sudo chown -R www-data:www-data richdocuments” (www-data or any other user/group you may be using)
Open your Nextcloud in your webbrowser and go to “settings” There you should find somewhere “collabora”. Open it and fill in the address of your Collabora online server.

I’m giving up. Although I finally managed to install and enable the 3.0.0 version, I now run into other problems. I guess I have to admit not having enough knowledge, experience and patience to set this up.

Thanks for the help.

Don’t give up too soon, there isn’t one wisedom as there are many variables. So knowledge and experience come when you allow yourself some patience and take steps at your own pace. Best way is to understand what you are doing instead of just following some guides or advice.

1 Like

Do you have a link for the nightly app? Github repository?

@mjanssens Thanks for the encouraging words, but currently I can’t find the perseverance to do this.

@kevdog Have you searched for ‘collabora 3.0.0 nightly’?

I’m guessing its here:
https://apps.nextcloud.com/apps/richdocuments

I’ve tested 3.1.1 now and its better then 3.0.0

I did a fresh installation of Ubuntu 18.04, Nextcloud 15.05 and Collabora Online 3.2.3., but unfortunately “Failed to load Collabora Online - please try again later”

WOPI discovery URL and Collabora Admin Console are working.

Please either post the error you are getting from the nextcloud.log or the httd-error.log. These are probably going to be located in the /var/log directory.

Apache error log:

[Thu Mar 07 20:13:14.163392 2019] [core:error] [pid 4438] [client 192.168.0.2:61796] Invalid status line from script 'index.php': 0
[Thu Mar 07 20:13:14.228916 2019] [fcgid:warn] [pid 4889] [client 192.168.0.2:61797] mod_fcgid: stderr: PHP Fatal error:  Cannot declare class GuzzleHttp\\Handler\\CurlFactory, because the name is already in use in /var/www/clients/client1/web7/web/3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php on line 15

That problem – the forum is littered with that error. I have no idea how to resolve this problem. I have the same problem and have never resolved. Look at this post. Near the bottom there is post about someone who temporarily switched domain names. GuzzleHttp Name Already in Use.

That worked for me!