Collabora - strange host in POST request


I’ve set up a CODE server and wanted to connect it to my nextcloud. Both Nextcloud and CODE servers run in LXC containers behind nginx reverse proxy. In Collabora Online settings my server’s URL is “” and it says that “Collabora Online server is reachable”.

When I try to open a document, I get an error “https ’s server IP address could not be found”. Example post request looks like https://https// Clearly the host name in this request is wrong, but why? Where does the redundant “https//” (with missing colon) come from?

Manually setting the public_wopi_url with occ config:app:set richdocuments public_wopi_url --value="" partially solved the problem. Now I’m getting another error: Content Security Policy: The page’s settings blocked the loading of a resource at https://https// (“form-action”).

1 Like