Collabora stopped working

Hey guys,
I recently installed nextcloud 13.0 on ubuntu 16.04 LTS with apache and also installed collabora according to the installation description (see link which is based on that guide)
Everything worked fine.

But now it stopped. I’m not sure if the nexcloud update to 13.0.1 created the problem or something else.
Everything I try to open results in an empty screen:


I checked the owncloud.log - nothing in there. I checked the docker log, nothing but the this warning:
wsd-00027-00028 19:59:41.053198 [ prisoner_poll ] WRN ForKit not responsive for 5734 ms forking 1 children. Resetting.| wsd/LOOLWSD.cpp:352
But I think this error is not the root cause of my problem.
I checked the apache logs - nothing found.

Oh one funny thing I also tried. I clicked a demo nextcloud instance - there is collabora already enabled and working. I replaced there collabora URL in the admin settings with my one and restarted my collabora docker with the proper demo nextcloud url:
docker run -t -d -p 127.0.0.1:9980:9980 -e 'domain=demo\\.nextcloud\\.com' --restart always --cap-add MKNOD collabora/code
And it worked. I saw CPU usage on my docker when working on documents, so I’m pretty sure it really runs on my collabora server ;-).
So the collabora part is working, but my nextcloud does not work with it.

Could you guys give me a hint where to look for errors? Or is it really a bug with 13.0.1??

Found the error!

It was my mistake by trying to enhance the security by using the suggested settings from ciperlist I added also the directive:
Header always set X-Frame-Options DENY
which results in an error in the browser web console saying:
Load denied by X-Frame-Options: https://[MyDomain].TLD/index.php/apps/richdocuments/index?fileId=250&requesttoken=[NumbersAndCharacters] does not permit framing.

So the solution is to comment out this line and collabora is back online :slight_smile:

1 Like