Collabora Standalone

Hallo Zusammen

Ich habe auf meine Truenas Nextcloud installiert was auch sehr gut läuft. Nun will ich auf einer VM auf der Ubuntu-Server läuft via Docker Collabora CODE installieren. Leider habe ich mit apache etwas mühe und hoffe Ihr könnt mir weiterhelfen.

im wesentlichen bin ich der Anleitung von Collabora Online (LibreOffice) für Nextcloud - Schritt für Schritt (Docker) gefolgt.

Ich habe einen separaten Reverse-Proxy der die Weiterleitung an den Collabora-CODE Server machen soll. Wenn ich office.xxx.duckdns.org eingebe lande ich auch auf der Apache default Seite.

auf dem Collabora-CODE Ubuntu Server habe ich Apache installier und die Module:
a2enmod proxy
a2enmod proxy_wstunnel
a2enmod proxy_http
a2enmod ssl
aktiviert.

/etc/apache2/sites-available/office.xxx.duckdns.org.conf erstellt mit folgendem Inhalt:

<VirtualHost *:80>
ServerAdmin webmaster@example.org
ServerName office.xxx.duckdns.org

Encoded slashes need to be allowed

AllowEncodedSlashes NoDecode

Container uses a unique non-signed certificate

#SSLProxyEngine On
#SSLProxyVerify None
#SSLProxyCheckPeerCN Off
#SSLProxyCheckPeerName Off

keep the host

ProxyPreserveHost On

static html, js, images, etc. served from loolwsd

loleaflet is the client part of LibreOffice Online

ProxyPass /loleaflet http://127.0.0.1:9980/loleaflet retry=0
ProxyPassReverse /loleaflet http://127.0.0.1:9980/loleaflet

WOPI discovery URL

ProxyPass /hosting/discovery http://127.0.0.1:9980/hosting/discovery retry=0
ProxyPassReverse /hosting/discovery http://127.0.0.1:9980/hosting/discovery

Main websocket

ProxyPassMatch “/lool/(.*)/ws$” wss://127.0.0.1:9980/lool/$1/ws nocanon

Admin Console websocket

ProxyPass /lool/adminws wss://127.0.0.1:9980/lool/adminws

Download as, Fullscreen presentation and Image upload operations

ProxyPass /lool http://127.0.0.1:9980/lool
ProxyPassReverse /lool http://127.0.0.1:9980/lool

Capabilities

ProxyPass /hosting/capabilities http://127.0.0.1:9980/hosting/capabilities retry=0
ProxyPassReverse /hosting/capabilities http://127.0.0.1:9980/hosting/capabilities

Der Reverse-Proxy macht https und postet mir immer die Apache-Default Seite. Wie kann ich erreichen das wenn der Reverse-Proxy office.xxx.duckdns.org aufruft ich per office.xxx.duckdns.org/loleaflet/dist/admin/admin.html auf der Collabora seite lande?

Gruss und Danke

Das Problem konnte gelöst werden in dem man -e “extra_params=–o:ssl.enable=false” hinzufügt
Im Webserver intern benötige ich keine ssl Verschlüsselung und von extern läuft dies über ein Reverse-Proxy

docker run -t -d -p 127.0.0.1:9980:9980 -e ‘domain=cloud\xxx.duckdns\.org’ -e “username=adm” -e “password=pwd” -e “extra_params=–o:ssl.enable=false” --restart always --cap-add MKNOD collabora/code

1 Like