Collabora - prevent save

So I noticed that collabora always saves opened files, even if you click X or close. How do you prevent saving unless explicitly clicked “Save” or “Save As”? Where are this basic options?
Note that I also don’t need any versioning because of btrfs filesystem with snaps enabled.


You can modify your server’s options as described in this page : online/ at master · CollaboraOnline/online · GitHub

  51 <idlesave_duration_secs desc="The number of idle seconds after which document, if modified, should be saved. Disabled when 0. Defaults to 30 seconds." type="uint" default="30">30</idlesave_duration_secs>
  52 <autosave_duration_secs desc="The number of seconds after which document, if modified, should be saved. Disabled when 0. Defaults to 5 minutes." type="uint" default="300">300</autosave_duration_secs>
  53 <always_save_on_exit desc="On exiting the last editor, always perform the save, even if the document is not modified." type="bool" default="false">false</always_save_on_exit>

I am running this integrated version which apparently creates temporary files.

coolwsd --config-file=/tmp/appimage_extracted_b84f9c7d50bb312e62f8a595d83ad2d8/etc/coolwsd/coolwsd.xml --disable-cool-user-checking --port=9983 --lo-template-path=/tmp/appimage_extracted_b84f9c7d50bb312e62f8a595d83ad2d8/opt/collaboraoffice --o:sys_template_path=/tmp/appimage_extracted_b84f9c7d50bb312e62f8a595d83ad2d8/ --o:security.capabilities=false --o:security.seccomp=false --o:child_root_path=/tmp/coolwsd.d8vErNGhha/jails --o:file_server_root_path=/tmp/appimage_extracted_b84f9c7d50bb312e62f8a595d83ad2d8/usr/share/coolwsd --o:ssl.enable=false --o:net.proxy_prefix=true --o:memproportion=50 --o:logging.file[@enable]=true[0][@name]=path[0]=/tmp/coolwsd.d8vErNGhha/coolwsd.log --o:welcome.enable=true --o:mount_jail_tree=false --o:user_interface.mode=default --o:allowed_languages=de_DE el en_GB en_US es_ES fr_FR hu it nl pt_BR pt_PT ru --pidfile=/tmp/

Also in /tmp/appimage_extracted_b84f9c7d50bb312e62f8a595d83ad2d8/etc/coolwsd/coolwsd.xml save on exit = false (supposedly default value). So it shouldn’t save, but it does.

This doesn’t do what @korenje wants, because if changes are made to the file, it will still automatically save these changes on exit.

@korenje As far as I know, it is not possible to disable the auto-save function completely, and thus create a behavior like in Libre Office on the desktop, where you can discard changes by closing the file without manually saving it. But to be sure, you may also ask here:

I’m not sure, but I think the OP is having the same issue I’m having: If you open a document just to view it, and immediately close it without making any changes, Collabora still saves it. always_save_on_exit and idle/autosave_duration settings don’t change this behavior.

This is a bummer, because it updates the ‘modified’ timestamp on every file you look at.