Collabora Online: SSL certificate is not installed

Hi everybody !
i am trying to build nextcloud with collobora and spreedme on ubuntu 14.04
i didt all of oficial tutorial but neither collobara nor spreedme could worked
i have signed certificates (startssl)
I am using mariadb10 and php5.6.*
i dont know where i have mistake
here is error message
Please ask your administrator to add ca-chain.cert.pem to the ca-bundle.crt, for example “cat /etc/loolwsd/ca-chain.cert.pem >> /resources/config/ca-bundle.crt” . The exact error message was: cURL error 60: SSL certificate problem: self signed certificate in certificate chain

Hi there!

I have exactly the same problem… configured apache with the ssl certificate from lets encrypt and also checked that the cert is working. I don’t have any idea whats missing here

hi, and did you add you ca-cert to your <nextclouddir>/resources/config/ca-bundle.crt ?

1 Like

Yes of course I did it but same result same error

20 Eki 2016 11:09 tarihinde “dev0” yazdı:

That is weird, I had a machine with a selfsigned cert, after I added the own CA to that file, it worked.
You are using actual certificates on both instances, the collabora and nextcloud?

Hi, i did an

locate ca-chain
cat /var/lib/docker/aufs/mnt/7b418·····19d2/etc/loolwsd/ca-chain.cert.pem >> /var/www/nextcloud/resources/config/ca-bundle.crt
service apache2 restart

when i was trying with docker i also did but same result now i have
collabora without docker but in this moment i have problem because i
updated collabora app on nextcloud so i must update manually collabora
codes too

You need also to copy your 2 self signed certs (one for the nextcloud server and one for the collabora online server) to ca-bundle.crt and restart apache

1 Like


After spending the night on the study of the problem, I found the reason.
"Stream wrappers now verify peer certificates and host names by default when using SSL/TLS"
I do not know what to do. :frowning:

which php version do you use ?

I use php5.6 but I just found solution.
To run collabora with nextcloud I need to assemble correct ca-bundle for my site. Now it works correctly.

Hi, I have done, what is described in your recommendations and it started to work.
One moment, the documents are available only for viewing. Perhaps you know what could be the problem?

The question is solved, need upgrade Collabora app to v. 1.1.16