Collabora Online [ loolwsd ] ERR Failed to bind to: IPv6 port

Nextcloud version _(eg, 12.0.3)_:
Operating system and version _(debian 9.1)_:
Apache or nginx version _(2.4.25-3+deb9u4)_: 
PHP version _(eg, 7.0+49)_:

The issue you are facing:

I am trying to integrate collabora online with my nextcloud 12 instance following the instructions at https://nextcloud.com/collaboraonline/

I noticed that despite the docker container of collab/code is running, docker logs shows lots of:
wsd-00027-00027 00:29:46.415744 [ loolwsd ] ERR Failed to bind to: IPv6 port: 32857 (errno: Bad file descriptor)| net/Socket.cpp:274

PS: The docker HOST has ipv6 disabled. I dont know why collab/code is blindly trying to bind to a ipv6 address.

I had the same issue, the following workaround works for me:

in /etc/loolwsd/loolwsd.xml change the following:

before:
all

after:
IPv4

1 Like

Try adding ‘–o:net.proto=IPv4’ to environment variable ‘extra_params’.

Minimal example:

docker pull collabora/code

docker stop test; docker rm test

docker run \
 -t \
 --name test \
 -e extra_params=--o:net.proto=IPv4 \
 --cap-add MKNOD \
 -e "SLEEPFORDEBUGGER=0" \
 -d collabora/code