Collabora Online has no option for Built-in CODE

I updated my NC to 19.0.0.12, so I can use Collabora Online (richdocuments: 3.7.0)
and Collabora Online - Built-in CODE Server (richdocumentscode: 4.2.403).
Sadly I don’t get an option like shown in this screenshot:

I only got the two “old” options:

Any ideas how to enable the Build-in option?

I have the same happening to me.

I just did a brand new install with the install wizard so that I could get CODE and Collabora up and running quickly and…

I’m not sure what steps to take to fix this. I don’t see any troubleshooting documentation for this situation.

You may need to go to the app store on your instance and install the app titled " Collabora Online - Built-in CODE Server".

It’s already enabled

image

Anyone knows how to install Collabora correctly in v19? I installed Collabora Online and Collabora Online Built In CODE Server.

When I open a document:

My docker-compose.yml:

version: '3'

services:

  db:
    image: mariadb
    container_name: nextcloud-mariadb
    networks:
      - nextcloud_network
    volumes:
      - db:/var/lib/mysql
      - /etc/localtime:/etc/localtime:ro
    environment:
      - MYSQL_ROOT_PASSWORD=
      - MYSQL_PASSWORD=
      - MYSQL_DATABASE=nextcloud
      - MYSQL_USER=nextcloud
    restart: unless-stopped

  app:
    image: nextcloud:latest
    container_name: nextcloud-app
    networks:
      - nextcloud_network
    depends_on:
      - db
    volumes:
      - nextcloud:/var/www/html
      - ./app/config:/var/www/html/config
      - ./app/custom_apps:/var/www/html/custom_apps
      - ./app/data:/var/www/html/data
      - ./app/themes:/var/www/html/themes
      - /etc/localtime:/etc/localtime:ro
    environment:
      - VIRTUAL_HOST=xy.domain.com
    restart: unless-stopped
    ports:
      - 380:80
      - 3443:443
volumes:
  nextcloud:
  db:

networks:
  nextcloud_network:

Same problem…
Did you find a soloution @lishevita?

I’d recommend you to check the System Requirements. In my case, I got a wrong platform.

You’re problem seems to be different. Have you tried to run the AppImage by the terminal on your server?
sudo -u www-data apps/richdocumentscode/collabora/Collabora_Online.AppImage
On an other server I got the error message:

fuse: failed to exec fusermount: No such file or directory

Cannot mount AppImage, please check your FUSE setup.
You might still be able to extract the contents of this AppImage
if you run it with the --appimage-extract option.
See https://github.com/AppImage/AppImageKit/wiki/FUSE
for more information
open dir error: No such file or directory

Then I installed the package fuse on my debian 10 system sudo apt install fuse. Then it worked for me.

NextCloud Version 20.0.3
Ubuntu Version 18.04

  1. Go to the website and download v0.1.8 for the above version of Nextcloud
    https://github.com/nextcloud/documentserver_community/releases/download/v0.1.8/documentserver_community.tar.gz
  2. Extract the tar file from the gz - documentserver_community.tar
  3. Copy the TAR to the /tmp directory on your NextCloud instance
  4. Extract the tar to the apps dir of your Nextcloud with this command. Mine was in /var/www/nextcloud/apps
    sudo tar -xvf /tmp/documentserver_community.tar -C /var/www/nextcloud/apps
  5. Restart your server and the Collabora Online Built-in CODE will be available to Enable in your apps.