Collabora Online Developer Edition 4.0 is here: edit documents on mobile and more!

Same here unfortunately. Using the web UI it says:
“Failed to load Collabora online - please try again later”. The log shows “Connection refused”. I did not change anything other than pulling new versions of the nextcloud and collabra docker images.

1 Like

My collabora container give me this

wsd-00033-00043 2019-02-12 09:24:33.502261 [ websrv_poll ] ERR  Requesting address is denied: ::ffff:172.17.0.1| wsd/LOOLWSD.cpp:1971

Im getting the same Error ( Requesting address is denied: ::ffff:172.17.0.1| wsd/LOOLWSD.cpp:1971) several times, but collabora is working by the way, this is happening since the first time i got collabora working, tried with 4 different versions o docker image and different collabora app versions aswell, still dont know where is the source of that ERR.
Collabora is working in web browser but not in android app, it stucks loading.

I would try to go back to an working collabora version. But which works? :man_shrugging::thinking:

{"convert-to":{"available":false},"hasMobileSupport":true,"hasTemplateSaveAs":true}

Did someone manage to get working CODE and Nextcloud with NGINX in front of both, so that NGINX communicates with CODE through pure HTTP (not HTTPS) ?
I assume both (NC and CODE) listening on the same domain and NGINX terminats SSL.
I spent a lot of time on it but without success.

Hi,

  Why would you want to communicate with CODE on HTTP ?

Communication on HTTPS from nginx to CODE works great here at our
university…

Cheers,

Thierry

because of exposing single URL to inet.
I suppose NC listens on “https://my.domain.com/mextcloud”, CODE listens on “https://my.domain.com/code” and the the whole “https://my.domain.com” serves nginx (with cettificates … etc) .
In this case hthe HTTPS between nginx and CODE does not make sense, only consumes more resources and slows down communication.

It is created so that it needs ssl. And the slowdown is marginally. The main communication is between your browser and collabora. And not between collabora and nextcloud. The front serving the certificates is still nginx.

The latest versions works. I just tested it today

Yep, I have these settings for the CODE container: --o:ssl.enable=false --o:ssl.termination=true

Still not working for me… “Failed to load Collabora online - please try again later”

I added the lines to my nginx configuration and this is my output:

Senzanome

I deleted the cache of my Nextcloud Android App (Android Settings // Apps / Nexctloud // Storage - delete cache) and now it works.

it wouldn’t work for me at all on android, even after adding the required proxy for hosting/capabilities, no matter what i tried, while working fine on iOS from the start… until i saw this github comment. you have to change the server your nextcloud points to to something else, apply, then change it back and re-apply because it caches the incorrect information (forever?).

i’m only adding this now because this page was the top search result for this issue when i was trying to resolve it today.

2 Likes

Thanks so much, that was way it never worked for me. Everything fine now!

I am struggling with this issue as well.

curl -k https://[ip-of-container]:9980/hosting/capabilities
{"convert-to":{"available":true},"hasMobileSupport":true,"hasTemplateSaveAs":true,"productName":"Collabora Online Development Edition"}

curl -k https://office.[publicdomain]/hosting/capabilities
{"convert-to":{"available":false},"hasMobileSupport":true,"hasTemplateSaveAs":true,"productName":"Collabora Online Development Edition"}

No relevant entries in Apache or container logs. CODE admin panel is accessible, opening documents in NextCloud fails with a nondescipt error message. VHost configuration is adapted from current documentation. I am at my wits’ end.Has anyone any pointers as to what I could do or enable to aid in debugging?

@silanea – I have a working configuration.

You’re going to have to describe your setup a little more in detail – probably better on a different thread.

Hello Silanea,

It’s been a while since you wrote that, but I am struggling with quite the same issue : my Nextcloud from time to time looses its connection with my Collabora. Both are containers, running on the same server.
When connection is lost, the curl command show “available”:false

How did you fix this ?

Thanks !