Collabora on Debian 8.x - anyone got it working, if yes how?

Hello @Snowyo,

thanks a lot for your dedication! I will take a detailed look at it later, it looks quite complete.

First thing I realize is that it’s about new installations. I already got a working Nextcloud setup (apache, LE, for about 4 years or so) and would like to integrate the docker way, which almost works. So hopefully I will be able to pull out some new insights about what doesn’t go well in my env (Deb Jessie 8.x, kernel 4.6, MariaDB, php 5.6).

Anyway, after following official guide and several hints (aufs problems etc.) I still got “ClientRequestHandler::handleRequest: BadRequestException: Invalid URI or access denied”.


You can also compile it manually and there is a thread for that too.

You almost always can compile it by your own, if you want to invest the time for it. And still there’s no warrant it will work.

But that was not my point. It’s mainly about using the (semi-)official docker container. I still haven’t got a confirmation about a functional implementation running the container on Deb Jessie 8.x.

I still am curious if anyone is able to confirm or to deny.

Anyone got it to work without the docker (I dislike these container solutions as they quickly become a maintenance headache)?
A while ago someone posted a short guide for Owncloud here:

The solution to my latest “connection error, try again” problem has been solved through Jakob42’s post, which pointed out to disable the “allow app only for group xxx” setting. Even if the user was in the specific group, it error’ed.

Maybe this would have solved it way before I tried every possible thing, including kernel upgrade to 4.6 and other stuff like redirecting http to https.

My now working setup:

Debian Jessie 8.X - Kernel 4.6,x (but maybe it already works with 3.16.x)
Apache, Letsencrypt for both (nextcloud & office)
Nc 10.0.0.RC1
Docker 1.12.x

Someone did make a guide somewhere in this thread:

I personally installed collabora without docker. It has some benefits to it but installation is very time and resource consuming. Updating it also is time consuming.

But hey, how often am I updating it, not like every day.


Thats nice to know you managed to compile. would love to hear how you did it so others can do it as well if you want to help that is :slight_smile:

I remember someone made a detailed guide on this on this forum. But here’s what I used:

just follow the instructions there.

i got it to work with docker, on two ubuntu and one debian machine. On the lan only machine I needed to download the ajax stuff and alter the links in the mounted dockercontainer. On debian I needed to update the kernel.

I’ll try to resume the knowledge so far for the Collabora docker container implementation on Debian 8.X, at least this resolved my “connection error, try again” issue.

Deb Jessie 8.6+
PHP 5.6.x
MariaDB 10.whatever.x
Apache / https with Letsencrypt for nextcloud & office vhosts
NC 10.0.0.RC1
[redirects of :80 http to :443 https for both vhosts - not sure yet if this is needed or just optional]

  • LINUX Kernel
    Seems kernel needs to be updated from 3.16.X to 4.X (4.7 works for me). It’s afaik about aufs, which is needed by docker (in general?) or specifically by this Collabora container. Kernel 3.16.x in standard Debian is missing something appearently.

  • Collabora nextcloud app
    Shouldn’t be restricted to any specific groups, even if the user is assigned to those groups.

Any other hints?


Did it worked for you ?

@faisalna yes, it finally did work.

I still have the :80 http redirect to :443 https, didn’t try it without yet.

ahh , but are you able to open documents ? or nope ?

Am trying to setup it on debian

@faisalna as I wrote - yes, everything works.

Sometimes (not often at all) I still get “connection error, try again”, but only when I’m stressing the app a lot (fast changes on edit/view mode) OR every time when I try in a text document to jump from an index to the respective chapter - then it opens a new browser tab and gives me the error.

But again - it works with all the functions (all those I tried).


Thans mate, let me try on my side as well and will update you asap

Oky, good luck - it would be about time for you to feel this moment of eternal victory when it works… it was like winning a gold medal :wink:

And coincidence was, at the same time I finally managed again (after several weeks) to make MS Office 2007 running on Wine (PlayOnLinux;) on my newly reinstalled Debian Notebook.

I tell you man - it was like taking the next step to existence, really - couldn’t believe it :wink:

wow… that is niceeeeee , I would love to know how

Give updates on your work, we will make it work :slight_smile:

Can this be run behind another NGINX reverse proxy? How would I configure that proxy to handle both next cloud and collabora in the VM?