Collabora nur von einer Cloud aus zu erreichen

Ich habe auf einem Server (Ubuntu 18.04, nginx 1.14.0, php7.2) zwei Nextcloud-Instanzen installiert, sowie Collabora Ć¼ber Docker.
cloud1.domain.tld kann ohne Probleme Dokumente ƶffnen, cloud2.domain.tld kann es nicht. Den Container habe ich mittels
docker run -t -d -p 127.0.0.1:9980:9980 -e 'domain=cloud2\\.domain\\.tld|cloud2\\.domain\\.tld' -e 'dictionaries=de en' --restart always --cap-add MKNOD collabora/code
gestartet.
Beim Versuch Ć¼ber cloud2 ein Dokument zu ƶffnen bleibt das Laden-Symbol, die Browser-Konsole wirft keine Fehlermeldung aus. Nur docker logs gibt mir folgendes:

wsd-00030-00079 2019-04-05 10:10:49.986972 [ docbroker_005 ] ERR  WOPI::CheckFileInfo failed with 302 Found| wsd/Storage.cpp:465
wsd-00030-00079 2019-04-05 10:10:49.988505 [ docbroker_005 ] ERR  Failed to add session to [/index.php/apps/richdocuments/wopi/files/24090_ocad8q0yolxf] with URI [https://cloud2.domain.tld/index.php/apps/richdocuments/wopi/files/24090_ocad8q0yolxf?access_token=WxVntJrHvcTLS6S8pPKMIBOhX5fmcpRm&access_token_ttl=0&permission=edit]: WOPI::CheckFileInfo failed| wsd/DocumentBroker.cpp:1094
wsd-00030-00079 2019-04-05 10:10:49.989883 [ docbroker_005 ] WRN  Child session [0036] not found to forward message: load url=https://cloud2.domain.tld/index.php/apps/richdocuments/wopi/files/24090_ocad8q0yolxf?access_token=WxVntJrHvcTLS6S8pPKMIBOhX5fmcpRm&access_token_ttl=0&permission=edit readonly=0 lang=de| wsd/DocumentBroker.cpp:1739
wsd-00030-00079 2019-04-05 10:10:50.072921 [ docbroker_005 ] ERR  Invalid or unknown session [0036] to remove.| wsd/DocumentBroker.cpp:1163
kit-00069-00032 2019-04-05 10:10:50.991024 [ loolkit ] WRN  Kit connection lost without exit arriving from wsd. Setting TerminationFlag| kit/Kit.cpp:2222
wsd-00030-00031 2019-04-05 10:10:50.991877 [ prisoner_poll ] WRN  Prisoner connection disconnected but without valid socket.| wsd/LOOLWSD.cpp:1783

Meine Suchen nach WOPI::CheckFileInfo failed with 302 Found brachten bisher Ć¼berhaupt nichts zu Tage, weswegen ich es dann doch einmal mit einem eigenen Forenbeitrag versucheā€¦

Es war tatsƤchlich ein DNS-Cache Problem. Mit anderen Worten: das Problem hat sich nach drei Tagen von alleine erledigt.