Collabora not working in Nextcloud 11

I installed collabora from the docker image. When I try to create a document, or edit and existing document I get this error


This is what the logs show…
T15:20:49+00:00",“method”:“GET”,“url”:"/index.php/apps/richdocuments/wopi/files/331848_oc9w6xz1g2vc/contents?access_token=AlbIqbfI7JscIT9qanhGwKPRwvitHII2&access_token_ttl=0&permission=edit",“user”:"–",“version”:“11.0.1.2”}
{“reqId”:“UkqkJwBMap2OkYRkPDx0”,“remoteAddr”:“172.17.0.2”,“app”:“no app in context”,“message”:“Can not decrypt this file, probably this is a shared file. Please ask the file owner to reshare the file with you.”,“level”:3,“time”:“2017-02-16T15:24:45+00:00”,“method”:“GET”,“url”:"/index.php/apps/richdocuments/wopi/files/331797_oc9w6xz1g2vc/contents?access_token=SvfzDeSRflENCj4MFit9mp2pHDUtcPd2&access_token_ttl=0&permission=edit",“user”:"–",“version”:“11.0.1.2”}
{“reqId”:“YkR5JhF6uMBKKtfp92n9”,“remoteAddr”:“172.17.0.2”,“app”:“no app in context”,“message”:“Can not decrypt this file, probably this is a shared file. Please ask the file owner to reshare the file with you.”,“level”:3,“time”:“2017-02-16T15:31:10+00:00”,“method”:“GET”,“url”:"/index.php/apps/richdocuments/wopi/files/331797_oc9w6xz1g2vc/contents?access_token=fy7vpJEVn8HDqwr4kzkSmPT0PQINl5f5&access_token_ttl=0&permission=edit",“user”:"–",“version”:“11.0.1.2”}
{“reqId”:“6duq5H86nFY0iJ6frkoO”,“remoteAddr”:“10.40.2.51”,“app”:“no app in context”,“message”:“Missing expected parameters in change user hook”,“level”:2,“time”:“2017-02-16T15:38:30+00:00”,“method”:“POST”,“url”:"/index.php/login",“user”:“rob@xxxxx”,“version”:“11.0.1.2”}
{“reqId”:“6duq5H86nFY0iJ6frkoO”,“remoteAddr”:“10.40.2.51”,“app”:“no app in context”,“message”:“Missing expected parameters in change user hook”,“level”:2,“time”:“2017-02-16T15:38:31+00:00”,“method”:“POST”,“url”:"/index.php/login",“user”:“rob@xxxxx”,“version”:“11.0.1.2”}
{“reqId”:“VGuzVkd7sxMx2gJ7acnm”,“remoteAddr”:“172.17.0.2”,“app”:“no app in context”,“message”:“Can not decrypt this file, probably this is a shared file. Please ask the file owner to reshare the file with you.”,“level”:3,“time”:“2017-02-16T15:38:48+00:00”,“method”:“GET”,“url”:"/index.php/apps/richdocuments/wopi/files/331860_oc9w6xz1g2vc/contents?access_token=CfgvtlJWG8qIqcKfga2mvMNsrY9kZ0M2&access_token_ttl=0&permission=edit",“user”:"–",“version”:“11.0.1.2”}
{“reqId”:“wJnaSz3AxKGQkGfm9ijT”,“remoteAddr”:“10.40.2.51”,“app”:“no app in context”,“message”:“Missing expected parameters in change user hook”,“level”:2,“time”:“2017-02-16T15:39:49+00:00”,“method”:“POST”,“url”:"/index.php/login",“user”:“rob@xxxxx”,“version”:“11.0.1.2”}
{“reqId”:“wJnaSz3AxKGQkGfm9ijT”,“remoteAddr”:“10.40.2.51”,“app”:“no app in context”,“message”:“Missing expected parameters in change user hook”,“level”:2,“time”:“2017-02-16T15:39:50+00:00”,“method”:“POST”,“url”:"/index.php/login",“user”:“rob@xxxxx”,“version”:“11.0.1.2”}
{“reqId”:“qS16aR/WGUT4I+oaVK0z”,“remoteAddr”:“172.17.0.2”,“app”:“no app in context”,“message”:“Can not decrypt this file, probably this is a shared file. Please ask the file owner to reshare the file with you.”,“level”:3,“time”:“2017-02-16T15:39:57+00:00”,“method”:“GET”,“url”:"/index.php/apps/richdocuments/wopi/files/331860_oc9w6xz1g2vc/contents?access_token=ke4jt2vryFEa5kSmd55h1ZH20JUum6Xe&access_token_ttl=0&permission=edit",“user”:"–",“version”:“11.0.1.2”}

Any help would be appreciated.

Any ideas on this?

have you enabled the server-side encryption.

If the user files are encrypted you cannot use collabora/code.

You can also not undo this however you may disable it and newer files will be accessable but you can no longer use the older encrypted files.

If you have not enabled server-side encryption then i have no idea.

Well this sucks, server-side encryption was one of the reasons we use nextcloud… pretty big limitation.