Collabora not responding on separate servers

I successfully installed Nextcloud 15 on a web dedicated server and it’s working fine. So I’m trying to install Collabora on a separate VPS server running on Debian 8. Following this official tuto everything looks ok, but when I try to open an .ods on my Nextcloud I get the “Failed to load Collabora […]” error.

My setup is simple :

  • A server with Nextcloud installed =
  • A VPS server on Debian 8 with Docker and Collabora = xx.xx.xx.xx.xx
  • I created the subdomain “” that is pointing to the Collabora ip successfuly.

I think the issue is coming from my reverse proxy settings. I used a2ensite to use /etc/apache2/sites-available/ as a config file, here it is :

<VirtualHost *:443>

# SSL configuration, you may want to take the easy route instead and use Lets Encrypt!
SSLEngine on
SSLCertificateFile	/etc/letsencrypt/live/
SSLCertificateChainFile /etc/letsencrypt/live/
SSLCertificateKeyFile /etc/letsencrypt/live/
SSLProtocol             all -SSLv2 -SSLv3
SSLHonorCipherOrder     on

# Encoded slashes need to be allowed
AllowEncodedSlashes NoDecode

# Container uses a unique non-signed certificate
SSLProxyEngine On
SSLProxyVerify None
SSLProxyCheckPeerCN Off
SSLProxyCheckPeerName Off

# keep the host
ProxyPreserveHost On

# static html, js, images, etc. served from loolwsd
# loleaflet is the client part of LibreOffice Online
ProxyPass           /loleaflet https://XX.xx.XX.xx.XX:9980/loleaflet retry=0
ProxyPassReverse    /loleaflet https://XX.xx.XX.xx.XX:9980/loleaflet

# WOPI discovery URL
ProxyPass           /hosting/discovery https://XX.xx.XX.xx.XX:9980/hosting/discovery retry=0
ProxyPassReverse    /hosting/discovery https://XX.xx.XX.xx.XX:9980/hosting/discovery

# Main websocket
ProxyPassMatch "/lool/(.*)/ws$" wss://XX.xx.XX.xx.XX:9980/lool/$1/ws nocanon

# Admin Console websocket
ProxyPass   /lool/adminws wss://XX.xx.XX.xx.XX:9980/lool/adminws

# Download as, Fullscreen presentation and Image upload operations
ProxyPass           /lool https://XX.xx.XX.xx.XX:9980/lool
ProxyPassReverse    /lool https://XX.xx.XX.xx.XX:9980/lool

# Endpoint with information about availability of various features
ProxyPass           /hosting/capabilities https://XX.xx.XX.xx.XX:9980/hosting/capabilities retry=0
ProxyPassReverse    /hosting/capabilities https://XX.xx.XX.xx.XX:9980/hosting/capabilities

Here, XX.xx.XX.xx.XX is the Collabora’s VPS server ip obviously. Then I restarted Apache+Docker after killing all containers and I tried to launch Collabora with the following command :

docker run -t -d -p 9980:9980 -e 'domain=cloud\\.mydomain\\.com' --restart always --cap-add MKNOD collabora/code

But Collabora looks like it’s not responding. I can’t access I get a 404 error.

Here is the output of some commands I tried :

I looked up on internet and it could be a common issue with Debian 8 coming from the docker aufs device system so I tried to switch for devicemapper without success. I followed this official tutorial, the loop-lvm method did nothing, when I run docker infothe device is still aufs. So I tried the “direct-lvm mode for production”. When using fdisk -l I can see this :

But the commands sudo pvcreate /dev/sda1 don’t work. I get the following error
“Can’t open /dev/sda1 exclusively. Mounted filesystem?”

I then tried to create a new partition using the following commands :
$ fdisk /dev/sda
$ n //to create a partition
$ p //for primary
$ 2 //for the partition number

But it return nothing, I tried with other numbers than 2 and with “e” for an extended partition instead of a primary one but nothing works.

I’m kinda new to all this stuffs so here I’m totally stuck.