Collabora not responding in Nextcloud

Hello everyone,

right now I’m trying to integrate the collabora docker container in our Nextcloud in our company.

Operating System: Ubuntu 18.04.1 LTS
Kernel: 4.15.0-65-generic
Webserver: Apache/2.4.29
Nextcloud Version: 18.0.1
Docker Version: 18.09.7, build 2d0083d

The docker container is running on the same machine as Nextcloud. Both sites have a different subdomain.

Cloud ->
Collabora ->

The Cloud is working fine.

This is the VirtualHost Configuration of the docker container (I followed the official guidelines at

<VirtualHost *:443>
#DocumentRoot /var/www/
ErrorLog /var/log/apache2/
LogLevel Debug
#Options -Indexes

#SSL configuration, you may want to take the easy route instead and use Lets Encrypt!
SSLEngine on
SSLCertificateFile /etc/letsencrypt/live/
#SSLCertificateChainFile /etc/letsencrypt/live/
SSLCertificateKeyFile /etc/letsencrypt/live/
SSLProtocol all -SSLv2 -SSLv3
SSLHonorCipherOrder on

#Encoded slashes need to be allowed
AllowEncodedSlashes NoDecode

#Container uses a unique non-signed certificate
SSLProxyEngine On
SSLProxyVerify None
SSLProxyCheckPeerCN Off
SSLProxyCheckPeerName Off
#SSLProxyCheckPeerExpire Off

#keep the host
ProxyPreserveHost On

#static html, js, images, etc. served from loolwsd
#loleaflet is the client part of LibreOffice Online
ProxyPass /loleaflet https:// retry=0
ProxyPassReverse /loleaflet https://

#WOPI discovery URL
ProxyPass /hosting/discovery https:// retry=0
ProxyPassReverse /hosting/discovery https://

#Main websocket
ProxyPassMatch “/lool/(.*)/ws$” wss://$1/ws nocanon

#Admin Console websocket
ProxyPass /lool/adminws wss://

#Download as, Fullscreen presentation and Image upload operations
ProxyPass /lool https://
ProxyPassReverse /lool https://

#Endpoint with information about availability of various features
ProxyPass /hosting/capabilities https:// retry=0
ProxyPassReverse /hosting/capabilities https://

The docker run command looks like this

docker run -d -t -p -e "domain=cloud\\.domain\\.com" --cap-add MKNOD --restart always collabora/code

When I type https:/ / I get the XML-File.
When I type https:/ / I get the admin-login panel.

This let me assume, that the container is working correctly.

However when I enter https:/ / in the collabora settings in the nextcloud, the documents won’t open. I get the following error:

In english it means something like: failed to load collabora online. please try again later

I noticed, that when I type https:/ / in the browser, apache redirect me to another virtualhost document root. That’s why I experimented with DocumentRoot shown in above configuration, but without success (I was sent to the correct document root but could not open any file in the cloud).

I tried this at home too. At home I have dynamic dns with just one domain and my cloud and collabora are running on different machines and on different ports on the router. This is working.

I appreciate any help in advance. If you need any further information about my configuration, just let me know.

PS: I had to put some spaces in the links, because I can’t add more than four links as a newbie. If there is an easy way to format links, so they won’t interpreted as a link, please let me know.


Dieser Text wird versteckt

Why does collabora need a domain name since its running on the same computer? Just a thought?

Do you have any logs from either the nextcloud side or collabora side you could post?
I’m curious if this is an SSL error?

What do you get if in your browser you type