Collabora installation // only white page at document


#1

Hi,

i installed collabora on the same machine i run my NC 14. No issues at installing with docker. But if i now click on a document in my NC. I only get a white page - collabora will not load.

Docker is running.

My apache config:

IfModule mod_ssl.c>
<VirtualHost *:443>
ServerName domainoffice.dedyn.io
ServerAlias office.domain.com
DocumentRoot /var/www/html

Include /etc/letsencrypt/options-ssl-apache.conf
SSLCertificateFile /etc/letsencrypt/live/domainoffice.dedyn.io/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/domainoffice.dedyn.io/privkey.pem

#-----------------------

Encoded slashes need to be allowed

AllowEncodedSlashes NoDecode

Container uses a unique non-signed certificate

SSLProxyEngine On
SSLProxyVerify None
SSLProxyCheckPeerCN Off
SSLProxyCheckPeerName Off

keep the host

ProxyPreserveHost On

static html, js, images, etc. served from loolwsd

loleaflet is the client part of LibreOffice Online

ProxyPass /loleaflet https://127.0.0.1:9980/loleaflet retry=0
ProxyPassReverse /loleaflet https://127.0.0.1:9980/loleaflet

WOPI discovery URL

ProxyPass /hosting/discovery https://127.0.0.1:9980/hosting/discovery retry=0
ProxyPassReverse /hosting/discovery https://127.0.0.1:9980/hosting/discovery

Main websocket

ProxyPassMatch “/lool/(.*)/ws$” wss://127.0.0.1:9980/lool/$1/ws nocanon

Admin Console websocket

ProxyPass /lool/adminws wss://127.0.0.1:9980/lool/adminws

Download as, Fullscreen presentation and Image upload operations

ProxyPass /lool https://127.0.0.1:9980/lool
ProxyPassReverse /lool https://127.0.0.1:9980/lool

<VirtualHost *:443>
ServerName domainNC.dedyn.io
ServerAlias nc.domain.com
DocumentRoot /var/www/nextcloud

Header always set Strict-Transport-Security "max-age=31536000; includeSubDomains; preload" Header always set Referrer-Policy no-referrer

<Directory /var/www/nextcloud/>
Options +FollowSymlinks
AllowOverride All

Dav off

SetEnv HOME /var/www/nextcloud
SetEnv HTTP_HOME /var/www/nextcloud

Include /etc/letsencrypt/options-ssl-apache.conf
SSLCertificateFile /etc/letsencrypt/live/domainoffice.dedyn.io/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/domainoffice.dedyn.io/privkey.pem


#2

Hi;

have the same issue:
https://help.nextcloud.com/t/collabora-on-nextcloud/40677

I found an error message when I use IE11, see in my post

greets
ferengie