Collabora in own docker image suddenly stopped working

Suddenly my Collabora integration stopped working.

When I go to the collabora tab, it says:

If I press save, all seems fine

But when I refresh the settings page, its back to the error above.

There is no error to be found anywhere I look.

I updated now from 18.04 to 18.05 and the latest collabora docker mage. But still the same behavior.

Also in the docker logs no reaction to all this at all. Is there a place I am missing that could shed some light onto this?

Hello,
I have docker too. Updates from nextcloud, collabora, docker always broke collabora.
To solve that, I reinstall collabora app, and make a pull for collabora docker.

Tried that. And I did not update anything when it broke.

I wonder about the lack of logs pointing to a reason.

Ok, I traced the code to capabilities.json being empty and found this beauty:

            try {
                    $response = $client->get($capabilitiesEndpoint, $options);
            } catch (\Exception $e) {
                    return [];
            }

Would have been good to see the result in logs somehow.

Checking the error content reveals this:

Client error: `GET https://office.xxxxxxxxxxxxx/hosting/capabilities` resulted in a `404 Not Found` response:
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found (truncated...)

now I at least know where to look

Ok,

adding

ProxyPass /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities retry=0
ProxyPassReverse           /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities

To my apache config on the docker host, solved the issue. But I have no F-ing clue how this worked before and why it suddenly stopped working…

1 Like

Oh… its not nc update which broke collabora but collabora update. Capabilities were a known issue which appeared since the last collabora app update.

Then I guess there was a different problem before that got exchanged by this problem after I updated in the hopes to fix the other problem. :confused:

The same problem after updating the application in the cloud of the collabora online … My collabora fell off which is spinning in the docker! I have a proxy configured to nginx how is it decided what needs to be added?