Collabora + HTTP + Apache + Docker = grey screen

Hello!

This is my configuration:

  1. Nextcloud running on my own PC with Apache server in HTTP.

  2. Collabora running in localhost under 9980 installed using the docker image and running this configuration:

    docker exec -it collabora_nextcloud /bin/bash -c "apt-get -y update && apt-get -y install xmlstarlet && xmlstarlet ed --inplace -u \"/config/ssl/enable\" -v false /etc/loolwsd/loolwsd.xml && xmlstarlet ed --inplace -u \"/config/ssl/termination\" -v false /etc/loolwsd/loolwsd.xml" --> to disable SSL.

  3. http://localhost:9980 returns “OK”

  4. The result: NC toolbar, Collabora and in place of the document, a grey screen.

Any help?

Regards!

Press F12 in the browser, go to console log, and find out why the iframe was not loaded.

Hello @timar, thanks for your answer.

I get this:

No idea :disappointed:

You wrote that http://localhost:9980 returned “OK”. Does http://192.168.52.146:9980 return “OK”, too? You can also set the log level to trace in loolwsd.xml, to have more verbose output.

http://192.168.52.146:9980 return “OK”, too?

Yes.

You can also set the log level to trace in loolwsd.xml, to have more verbose output.

How can I do that?

I don’t have the file /var/log/loolwsd.log (if you mean that)

I’m under a proxy, may be it’s something about that?