Collabora fails to open files with "unknown format" error - Nextcloud on UCS 4.3


I did a fresh install of Nextcloud 13.0.5-0 and Collabora Developer Edition on UCS 4.3. I’m also using the Let’s encrypt certificates. Nextcloud works fine and I can login to the Collabora admin console.

If I try to open a file in Nextcloud with Collabora, Collabora loads but tells me that the format of the file is incompatible (see german screenshot)

This happens for all files I tried, even empty new ones. How can I debug that?

I’m suspicious that this has something to do with DNS and SSL certificates, but the setup should be fine:

  • I’m using a public FQDN for the instance
  • the Let’s encrypt certificate is working
  • the internal CA of UCS is known to the Nextcloud docker container

Any hints?

What helped me every time in the past was a “systemctl restart docker” on the UCS server. Especially after updating the Collabora UCS-App.

Tell me if it worked.

Thanks for the answer, but it made no difference. I also restarted the whole server after the latest UCS Errata updates, with no change in the behavior.

As mentioned the Collabora admin interface works, and I can also see there that there has been attempts to open a file. But I have no idea how to debug this. Are there any logs or something I should have a look at?

Are the NC and Collabora containers on the same UCS host? Maybe you should try to stop the Collabora container first, then restart the NC container and wait some minutes and only then restart the Collabora container. Possibly there’s something with the docker networking going on. Just a guess. Good luck.

Restarting the host or the container (using the “docker” stop/start command) was no success. In both cases no real restart of the services in the container occured, only a “suspend”.

I resolved the problem by initiating a “shutdown” of collabora in the admin web interface, which actually was more like a restart. A few moments after the “shutdown” the service worked fine.