Collabora - Everything works, but can't save documents

I got Collabora up and running (with Apache behind an nginx reverse proxy), and I can open up documents and make changes, but those changes never get saved.

Right now I’m thinking this is a permissions issue for my docker container, my Nextcloud data directory is on a separate zfs volume than my host OS, not sure if anyone else had this issue? I’m new to docker but thinking the solution might be to add DAC_OVERRIDE to the capabilities? Maybe there’s also a more precise way to give the container permissions to just my data directory with docker capabilities or the -v option?

I’m also having the issue where my documents open one out of every three or four attempts, not sure if that’s related or not (it seems to happen right after I successfully open a document, then try to save it and the changes get wiped).

docker logs gives me this:
wsd-00026-0442 0:05:55.376535 [ child_ws_417 ] ERR LOOLSession::handleInput: Exception while handling [unocommandresult: {...] in ToPrisoner-0010: No message received| LOOLSession.cpp:241

Still getting the same error after running docker with --privileged, I was looking at this thread for ideas but nothing seems to be working (so far I’ve disabled the other Documents app, ran docker with -v pointed to my storage volume)

I haven’t found anything so far that references the error I’m getting. Any help would be greatly appreciated!

EDIT: Also created an issue on Github, so here’s the other stuff I’ve tried without success:

  • Running docker with --net host
  • Making sure another app running on the same server that uses websockets wasn’t getting in the way
  • Trying to access /lool/adminws, but now getting this error from Apache, despite making sure that all the required mods were enabled/loaded;
    No protocol handler was valid for the URL /lool/adminws. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.

I think I’m getting closer, but there must be some misconfiguration that isn’t proxying the websockets correctly, and it seems like that’s what Collabora needs to make the edits?


I am facing this same issue since I’ve instaled native packages of Collabora Online in Ubuntu 18.04. I can open files but cannot save them (in Nextcloud logs the error message is: Private Key missing for user: please try to log-out and log-in again).
Also, when I try to save, then the files get corrupted with empty content.

Before I was dock version of Collabora without problems.

Using latest stable Nextcloud.

Any Ideas? Thanks.

Ok, tested again with latest docker and I have the same problem…

Maybe linked to :

I think not. I’ve tested pulling the collabora/code: and the same thing is happening. Also, is different since I can not save documents, no natter if new file or existent one.

Also, like I said, is I am editing an existent file, it makes empty after a failed save.

Sorry for not updating everyone, I totally forgot this thread existed. In this case my issue was that my web application firewall rules for nginx were actually blocking legitimate traffic from/to my Collabora instance. When I tweaked those saving works for me.