Collabora: Doesn´t get any menu ribbon

Hi,

I´ve installed collabora docker image and the collabora app at nextcloud. I followed the instructions from: https://nextcloud.com/collaboraonline/ and https://icewind.nl/entry/collabora-online/ (nginx).

When I visit the /hosting/discovery I get a valid XML and a source link e.g. /loleaflet/2.0.3/loleaflet.html does work. But I can´t see any menu ribbon at nextcloud which is called office. Also when I click on a document Collabora doesn´t load. Instead I get the error within Nextcloud “Access forbidden”.

I´ve checked the nginx error, nextcloud log - but no log entries. Has anyone a hint how I can debug the collabora app? My nginx server config for nextcloud is:

server {
    listen 443 ssl http2;
    server_name cloud.xy.de;
    ssl_certificate /etc/letsencrypt/live/cloud.xy.de/fullchain.pem;
    ssl_certificate_key /etc/letsencrypt/live/cloud.xy.de/privkey.pem;
    add_header Strict-Transport-Security "max-age=63072000; preload";
    add_header X-Content-Type-Options nosniff;
    add_header X-Frame-Options "SAMEORIGIN";
    add_header X-XSS-Protection "1; mode=block";
    add_header X-Robots-Tag none;
    add_header X-Download-Options noopen;
    add_header X-Permitted-Cross-Domain-Policies none;
    root /var/kunden/cloud/httpdocs/nextcloud;

    location = /robots.txt {
            allow all;
            log_not_found off;
            access_log off;
    }

    location = /.well-known/carddav { return 301
            $scheme://$host/remote.php/dav; }
    location = /.well-known/caldav { return 301
            $scheme://$host/remote.php/dav; }

    location /.well-known/acme-challenge { }

    # set max upload size
    client_max_body_size 2G;
    fastcgi_buffers 64 4K;
    gzip off;

    error_page 403 /core/templates/403.php;
    error_page 404 /core/templates/404.php;

    location / {
            rewrite ^ /index.php$uri;
    }

    location ~ ^/(?:build|tests|config|lib|3rdparty|templates|data)/ {
            deny all;
    }

    location ~ ^/(?:\.|autotest|occ|issue|indie|db_|console) {
            deny all;
    }

    location ~ ^/(?:index|remote|public|cron|core/ajax/update|status|ocs/v[12]|updater/.+|ocs-provider/.+|core/templates/40[34])\.php(?:$|/) {
            fastcgi_split_path_info ^(.+\.php)(/.*)$;
            include fastcgi_params;
            fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
            fastcgi_param PATH_INFO $fastcgi_path_info;
            fastcgi_param HTTPS on;
            fastcgi_param modHeadersAvailable true;
            fastcgi_param front_controller_active true;
            fastcgi_pass unix:/var/run/php/php7.0-fpm-cloud.sock;
            fastcgi_intercept_errors on;
            fastcgi_request_buffering off;
    }

    location ~ ^/(?:updater|ocs-provider)(?:$|/) {
            try_files $uri/ =404;
            index index.php;
    }

    location ~* \.(?:css|js)$ {
            try_files $uri /index.php$uri$is_args$args;
            add_header Cache-Control "public, max-age=7200";
            add_header X-Content-Type-Options nosniff;
            add_header X-Frame-Options "SAMEORIGIN";
            add_header X-XSS-Protection "1; mode=block";
            add_header X-Robots-Tag none;
            add_header X-Download-Options noopen;
            add_header X-Permitted-Cross-Domain-Policies none;
            access_log off;
    }

    location ~* \.(?:svg|gif|png|html|ttf|woff|ico|jpg|jpeg)$ {
            try_files $uri /index.php$uri$is_args$args;
            access_log off;
}

}

Nginx server block for collabora:

server {
    listen       443 ssl;
    server_name  office.xy.de;

      ssl_certificate /etc/letsencrypt/live/office.xy.de/fullchain.pem;
      ssl_certificate_key /etc/letsencrypt/live/office.xy.de/privkey.pem;

    location / {
        proxy_pass https://127.0.0.1:9980;
        proxy_set_header Host $http_host;
    }

    # static files
    location ^~ /loleaflet {
        proxy_pass https://127.0.0.1:9980;
        proxy_set_header Host $http_host;
    }

    # WOPI discovery URL
    location ^~ /hosting/discovery {
        proxy_pass https://127.0.0.1:9980;
        proxy_set_header Host $http_host;
    }

    # websockets, download, presentation and image upload
    location ^~ /lool {
        proxy_pass https://127.0.0.1:9980;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
        proxy_set_header Host $http_host;
    }
}

Does nginx block anything?

1 Like