Collabora does not work

I use snap NC 21.0.3 snap2 on my Ubuntu server 20.04.3
Collabora Online 4.2.2
Collabora Online - Built-in CODE Server 6.4.1004

My problem:
When I try to open office documents (xlsx, docx…) via Collabora I see only a blank white page. Collabora does not load itself.
It does not matter if my connection is via LAN address or outside of the internet via my domain.
I use Build-in CODE - Collabora online edition.

I am sure that it worked few versions back.
Can you please help me?
Thank you.

collabora_blank

My Nextcloud SNAP was updated to version 21.0.4 SNAP1 but nothing happened.
Collabora Online - Built-in CODE Server 6.4.1004 - does not work.

I tried to downgrade richdocumentscode to version 6.4.608 but it did not help. I still see a blank page.
I also tried other versions …6.4.705…704…703… but nothing works for me.

I find out there is possible to use a docker as well.
My Ubuntu Server supports docker so I tried to make it work but there is some problem I cannot fix because when I route connection via my NGINX server.
My Nextcloud server does not see my Collabora Online docker.

Nextcloud and NGINX are on the same LAN. My other dockers work fine.
Maybe somebody can help me with the docker solution instead of richdocumentscode version, please?