Collabora : Document cannot be saved to storage

Hello to all,
I remain with NC13 for a long time after I saw on NC14 a trouble to save the paperwork done w/ Collabora. I got this message if i click on the floppy-disc to save :
Document cannot be saved to storage. Check your permissions or contact the storage server administrator.
Of course, before checking w/ the floppy-disc I had lost automatically saved :grimacing:
Then I install NC15 and same, I still couldn’t save any Collabora documents to storage.

I thought that could be the NFS data storage.
Could it be permission on the files
A corrupted data could be the culprit.

To be sure that it was any of these possibilities, I verified that it wasn’t the case simply with a fresh install of NC15 without any data and not using NFS.

Another possibility a conflict with Version app

Nope, same nasty message again

The only thing that I didn’t tried is to reinstall completly the ReverseProxy . But as Collabora “works” in all the other aspects I see no reason for that.
We no longer can use Collabora that become too risky for documents, even the one created off line. I know that several people had this trouble, but I couldn’t see any clear solution that I could apply…
So thanks for helping me to repair this.


I too recently faced the same issue(version 15.0.14).I thoroughly verified the following

  1. NFS
  2. File permission on directory and sub-directories also compared with different user directory.
  3. A chance of data curruption

I found that the issue with an app version.I tried to downgrade with the last working version. Also, verify it with occ.
The last thing that needed to be done is upgrade nextcloud version to the stable or production version.