Collabora Connector Hangs, Crashes Firefox

Okay, I’ve mostly tried the collabora connector with compiled and installed loolwsd, loleaflet and LibreOffice following, however I’ve also tried it with the docker version. Everything seems to be working, when I go to HOSTIP:9980 I see “okay”. Fine.

But when I try to access the test document specified by “https://localhost:9980/loleaflet/1.9.0/loleaflet.html?file_path=file:///opt/loolwsd/test/data/hello.odt” I get the “Service is unavailable. Please try again later and report to your administrator if the issue persists.” When I try to connect through the OwnCloud web, going to the ‘Office’ app runs a script that crashes asking to be killed after a few seconds the brings up the documents, but when attempting to edit one I get a 404 error. If I try to connect with NextCloud then it hangs forever.

I’ve had a look at my loolwsd log and three errors get repeated;

ERR FileServerRequestHandler: File not found: /opt//loleaflet/dist/branding.js
ERR Failed to write to pipe. Data: [spawn 1]. (errno: Bad file descriptor)| IoUtil.cpp:216
ERR ClientRequestHandler::handleClientRequest: WebSocketErrorMessageException: error: cmd=socket kind=serviceunavailable| LOOLWSD.cpp:1160

The first error with the double / seems pretty obvious, but I have no idea how to change it.

I’ve been troubleshooting this for a while now. Does anyone have any suggestions?

Yeah, using the Docker image I get the same result. When I click ‘stop script’ everything runs, but I cannot edit the documents. Clicking on them just opens up the download dialog for that file.
Trying to start a new file opens up a duplicate tab of the office app that then crashes firefox again.