Collabora Built-in CODE stops working after OS reboot

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): Nextcloud Hub 3 (25.0.2)
Operating system and version (eg, Ubuntu 20.04): Lubuntu 22.04 LTS
Apache or nginx version (eg, Apache 2.4.25): 2.4.54
PHP version (eg, 7.4): 8.1

The issue you are facing:
Collabora Built-in CODE stops working after OS reboot (i.e. being prompted to download a document file instead of opening it)

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

  1. Enable “use the built-in CODE…”. Everything works ok. Documents from Files can be opened and edited just fine.
  2. Reboot the OS (Lubuntu in this case)
  3. Collabora stopped working. I.e. Being prompted to download files.
  • the CODE server is reported as available
  • the same issue happens when using the standalone CODE server (i.e. "use your own server, I’ve installed Collabora on the same server hosting Nextcloud - coolwsd & code-brand)
  • the issue can be quickly “fixed” by doing any of the following under Administration > Nextcloud Office:
    – switch between “use your own server” and “use the built-in…”. When doing this the message “setting up a new server…” show up (every time I switch). Then everything starts working again right away until a reboot occurs. This behavior can be reproduced consistently.

Do I need to set to some services to automatically start?
Is this behavior by design? (both built-in CODE and standalone were installed on brand new NextCloud instance by using the instructions on the Collabora website)
In the case of the standalone CODE server, after restart, I can see the coolwsd service as started and ok. In both cases after restart (built-in CODE and standalone), the status under Administration is “server is reachable” when it’s not working.

Thanks,
Adrian

There are several open issues about this problem on GitHub. Some users also seem to have found workarounds that you might want to try out…

1 Like

I am having the same issue. It’s related to apache being restarted.
You literally need to login as admin again, click settings, office, and click “use own server” until green icon appears. Only then the server will start. I noticed that it also keeps switching selection to “use integrated package CODE” for some reason.

Thank you!! The “dirty fix” described bellow worked for me.

As suggested by ernolf at the link below I created a service then enabled it:

But then across restarts the newly created service state was “failed”. But if I manually started the service with “sudo systemctl start richdocuments.service” it worked. So I made the fix even “dirtier” by creating a cron job to run the service at computer startup. To make sure that it will run I also added a 30 sec delay before starting the service.

2 Likes