Collabora blank screen on ubuntu 20.04 with nextcloud 20.0.11

Hi,

Description
Having issue to configure collabora (deployed through nextcloud apps service) : when opening a document, the “builtin code sever is starting…” message is displayed and then server returns a blank screen.

versions
OS : Ubuntu 20.04.2 LTS (Focal Fossa), deployed in VM vmware
Nextcloud : 20.0.11 (zip installation)
Apache : 2.4.41 (Server built: 2021-06-17T18:27:53)
Php: 7.4.3 (cli) (built: Jul 5 2021 15:13:35) ( NTS )
collabora online built-in code server application : 6.3.1004
collabora online application : 3.8.3

Collabora settings

  • “Collabora online server is reachable” message is displayed
  • “use the built-in CODE - Collabora online edition” is checked

"suspicious" apache error log message

[…]
Logging at warning level to file: /tmp/loolwsd.ZOvpjz7vIQ/loolwsd.log
Security: loolforkit incorrect user-name, other than ‘lool’
Security: Check for the ‘lool’ username overridden on the command line.
[…]
Security: loolmount incorrect user-name, other than ‘lool’
Aborting.

Screenshot 2021-07-21 at 15.12.33

full error log

$ cat error.log
[Wed Jul 21 13:19:57.652455 2021] [mpm_prefork:notice] [pid 1716] AH00163: Apache/2.4.41 (Ubuntu) OpenSSL/1.1.1f configured – resuming normal operations
[Wed Jul 21 13:19:57.652890 2021] [core:notice] [pid 1716] AH00094: Command line: ‘/usr/sbin/apache2’

Logging at warning level to file: /tmp/loolwsd.SXvY0iJwqf/loolwsd.log
Security: loolforkit incorrect user-name, other than ‘lool’
Security: Check for the ‘lool’ username overridden on the command line.
Init vcl
preload: merged unordf ucpchelp1 msforms vbaobj pcr vbaswobj sw animcore hwp flash chartcore solver sc wpftcalc xof ucpcmis1 wpftdraw sd svgfilter evtatt graphicfilter wpftimpress sdfilt sm pdffilter PresentationMinimizer protocolhandler ucpdav1 wpftwriter msword writerfilter t602filter xmlfa basctl binaryurp uuresolver scd chartcontroller ldapbe2 dba sdbt deploymentgui migrationoo2 migrationoo3 xsltfilter sdd embobj emboleobj log expwrap odfflatxml textfd storagefd xmlfd frm fwl fwm io textconversiondlgs smd mozbootstrap oox scfilt slideshow proxyfac vclcanvas canvasfactory mtfrenderer simplecanvas dlgprov basprov stringresource dbaxml calc dbase flat writer reflection bootstrap introspection invocation invocadapt namingservice stocservices cached1 ucppkg1 srtrs1 ucptdoc1 xsltdlg swd cui bib guesslang numbertext offacc scn scriptframe dbpool2 xmlsecurity analysis date pricing fps_office i18nsearch xsec_xmlsec emfio vbaevents pdfimport mysql_jdbc ucpext hyphen spell lnth for ctl passwordcontainer svgio
Absent (often optional): sm sm sm sm sm sm sm sm sm sm sm smd
Disabled: ucpftp1 rptxml dbu rptui rpt mork odbc sdbc2 cmdmail syssh ucphier1 ucpimage PresenterScreen abp dbp updatefeed
Whitelisted languages: de_DE el en_GB en_US es_ES fr_FR hu it nl pt_BR pt_PT ru
Preloading dictionaries: de_DE en_US fr_FR it_IT nl_NL pt_BR ru_RU en_GB nl_BE pt_PT es_ES
Preloading thesauri: de_DE en_US fr_FR it_IT nl_NL pt_BR ru_RU en_GB nl_BE pt_PT es_ES
Preload icons
Preload languages
Preload fonts
Ready to accept connections on port 9983.

Security: loolmount incorrect user-name, other than ‘lool’
Aborting.
Security: loolmount incorrect user-name, other than ‘lool’
Aborting.
Security: loolmount incorrect user-name, other than ‘lool’
Aborting.

Thanks in advance for your help
Guillaume

I have the same blank screen as well with the bultin server as with the official collabora packages.

My setup is:
Internet->HAProxy->Nginx->nextcloud/collabora

HAProxy is on a different machine.
Nginx, nextcloud and collabora are on the same VM.

In the settings of the collabora app in nextcloud I do have a verified connection to the collabora server.

In loolwsd.xml:

  • ssl is disabled
  • ssl_termination is enabled
  • host is allowed

<host allow=“true” desc=“Regex pattern of hostname to allow or deny.”>nextcloud\.domain\.com</host>
<host allow=“true” desc=“Regex pattern of hostname to allow or deny.”>collabora\.domain\.com</host>

In nginx error logs I see following entry:

[error] 18677#18677: *45500 connect() failed (111: Connection refused) while connecting to upstream, client: >>IP of HAProxy<<, server: nextcloud.domain.com, request: “GET /loleaflet/fcb0905/branding.css HTTP/1.1”, upstream: “http://[::1]:9980/loleaflet/fcb0905/branding.css”, host: “nextcloud.domain.com

Collabora server seems to be online

curl localhost:9980
OK#

I can also login as admin by vIsiting collabora.domain.com/loleaflet/dist/admin/admin.html but I get an error “Server has been shut down; please reload the page.”

I have tried to install different versions of collabora in nextcloud too (4.2.0, 4.1.2 and 4.1.1) they all behave the same way.

I would be very happy about some hints what I should change in my settings.