Collabora app not working when upgrading from Nextcloud 12 to Nextcloud 13


I upgraded from Nextcloud 12 to Nextcloud 13. All looks good. One issue however is that the + create new file menu no longer shows my Collabora online options for those types of rich text files. I only see the stock options of .txt file and folder or upload:

35 AM

I used to see:

31 AM

I did disable the app and re-enable it. I am getting no errors in my NC log files for this app. I also tried removing the app entirely from NC13 and re-enabling it. I still get no luck.

Also if I click on a previously viewable .odt file it just downloads it as if the app is not installed. the issue is not my Collabora service as that is active and unchanged.

Any issues people have had with this after upgrading Nextcloud?



since logging this topic I have since reverted the Collabora app from 2.0.4 (latest) to 2.0.3 which I had on my Nextcloud 12 before my upgrade and this has not solved the issue. I am still not getting the Collabora document added to my Nextcloud create new file menu!

Leads me to think this is a NextCloud core issue!?

I’m just wondering if anybody here has Collabora online app working successfully on Nextcloud 13?

Would appreciate a response as Nextcloud 13 looks great but without the Collabora app I will need to stay on 12.

Any help appreciated.


So if I disable the FullTextSearch apps I can get this to work now on NC 13! :face_with_raised_eyebrow:

It would appear that some apps can interfere with others in the NC app setup.

I have re-enabled fulltextsearch apps and it then stops collabora agian. I would have thought that there would not be a way for other apps to interfere with each app and how it works with Nextcloud.

Hope this helps somebody else who will have the issue inevitably!

Good luck! :clown_face:

HI Col,

I have collabora 2.0.5 on a nextcloud 13.0.1
I stumbled upon this topic… checked for FullTextSearch… all of them seem to be Beta… it seems more a FullTextSearch App issue then a Collabora issue…

By the way, this issue is reported here:


1 Like

Thanks Pieter.

I believe it is indeed a FullTextSearch app issue where it is blocking Collabora from working. I did not debug my vagrant version with the apps on it in details but with those apps disabled I can get Collabora to work fine.

Thanks for pointing out the topic. I will follow the issue on github and when I fix comes available I will give the FullTextSearch another go.