Client only transfers 100 files at a time?

Nextcloud version: 27.1.1
Operating system and version: Rocky Linux 9
Apache version: 2.4.53
PHP version: 8.0

The issue you are facing:

I just install nextcloud and went to sync my files, but it’s syncing my files in blocks of 100 only? Like it will upload 100 files, stop for about 5-10 secounds, then upload 100 more. I know the drives can handle moving more files at one time than this.


I have a reverse proxy running with Nginx too, which i am aware will cut speed down considerably because of cloudflare’s anti-ddos. Which is why I also have a LAN IP allowed to (to go directly to apache instead), which does see the expected transfer speeds with large files, but it has the above issue with small files still.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => '***',
  'passwordsalt' => '***',
  'secret' => '***',
  'trusted_proxies' => [''],
  'trusted_domains' =>
  array (
    0 => 'nextcloud.***.***',
    1 => '',
  'datadirectory' => '/storage',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://nextcloud.***.***',
  'overwriteprotcol' => 'https',
  'dbname' => 'mariadb',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'oc_32294',
  'dbpassword' => '***',
  'installed' => true,
Apache config
ServerRoot "/etc/httpd"

Listen 80

Include conf.modules.d/*.conf

User apache
Group apache

ServerAdmin root@localhost

<Directory />
    AllowOverride none
    Require all denied
    LimitRequestBody 400000000000

DocumentRoot "/var/www/sub-domains/nextcloud.***.***/html/"

<Directory "/var/www">
    AllowOverride None
    # Allow open access:
    Require all granted

<Directory "/var/www/sub-domains/nextcloud.***.***/html/">

    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted


<IfModule dir_module>
    DirectoryIndex index.html

<IfModule dir_module>
    DirectoryIndex index.html

<Files ".ht*">
    Require all denied

ErrorLog "logs/error_log"

LogLevel warn

<IfModule log_config_module>

    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%h %l %u %t \"%r\" %>s %b" common

    <IfModule logio_module>
      LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio

    CustomLog "logs/access_log" combined

<IfModule alias_module>

    ScriptAlias /cgi-bin/ "/var/www/cgi-bin/"

<Directory "/var/www/cgi-bin">
    AllowOverride None
    Options None
    Require all granted

<IfModule mime_module>
    TypesConfig /etc/mime.types

    AddType application/x-compress .Z
    AddType application/x-gzip .gz .tgz

    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml

<IfModule mime_magic_module>
    MIMEMagicFile conf/magic

EnableSendfile on

IncludeOptional conf.d/*.conf                                                                                                                                                                        

You can change the max number of parallel jobs the client handles:

For your apache, you normally have more settings, if you hit these limits often the logs tell you to consider to raise the limit (number of threads, number of connections…)